ROS软路由论坛 ROSABC.com

 找回密码
 会员注册
查看: 17952|回复: 86

[Configuration基础配置] [RouterOS 备份与复位管理] -- 系统备份 -- 系统通过备份文件

  [复制链接]
发表于 2013-4-21 01:24:11 | 显示全部楼层 |阅读模式
ROS软路由论坛
本帖最后由 rosabc 于 2013-4-21 01:57 编辑

RouterOS 备份与复位管理

-- 系统备份

-- 系统通过备份文件还原

-- 导出配置

-- 导入配置

-- 系统复位

RouterOS 可以通过 backup 将系统备份为二进制文件,采用 FTP 访问或通过在 winbox 中的 file 中下载备份文件,并可

以通过备份文件还原路由器设置。

RouterOS 通过导出配置文件,可生成文本文件(可编辑脚本),同样使用 FTP 或通过在 winbox 中的 file 中下载文件,导 入配置则将脚本文本文件导入路由器。

系统复位是将所有的配置信息从 RouterOS 中全部删除掉,在做此操作前,最好先将路由器的配置备份一次。

注: 为了保证备份不会失败,请在将备份的文件恢复到同样的软件版本和同样的硬件配置上去

系统备份

操纵路径:/system backup

Save 指令是保存当前配置到一个备份文件中,显示文件在/file 目录中。如需要回复指定的备份文件,可通过/system backup 中的 load 指令载入配置,还原系统。

指令描述

load name=[filename] – 载入备份文件的配置

save name=[filename] – 保存当前的配置到文件中

例如:

将当前的配置保存到文件 test:


[RouterOS@ROSABC] system backup> save name=test
Saving system configuration Configuration backup saved
[RouterOS@ROSABC] system backup>

在路由器中查看保存的文件:


[RouterOS@ROSABC] > file print
# NAME TYPE SIZE CREATION-TIME
0 test.backup backup 12567 aug/12/2002 21:07:50
[RouterOS@ROSABC] >

导入备份文件 test:


[RouterOS@ROSABC] system backup> load name=test
Restore and reboot-- [y/N]: y
...

Winbox 下配置直接在 files 菜单下,通过 backup 和 restore 操作
游客,如果您要查看本帖隐藏内容请回复



导出指令(Export)

指令名称:export

Export 指令用于导出脚本配置信息,这个命令可以在任何目录下。export 同样也可以通过 file 生成脚本配置文件,可用

FTP 或者进入 winbox 下载,并进行编辑。

指令描述

from=[number] – 指定需要导出的项目编号

file=[filename] – 保存的文件名称。

例如:


[RouterOS@ROSABC] > ip address print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 10.1.0.172/24 10.1.0.0 10.1.0.255 bridge1
1 10.5.1.1/24 10.5.1.0 10.5.1.255 ether1
[RouterOS@ROSABC] >

制作一个导出文件:


[RouterOS@ROSABC] ip address> export file=address

[RouterOS@ROSABC] ip address>

在路由器中查看导出的文件:


[RouterOS@ROSABC] > file print
# NAME TYPE SIZE CREATION-TIME
0 address.rsc script 315 dec/23/2003 13:21:48
[RouterOS@ROSABC] >

在不创建导出文件名,使用同样的指令导出显示出配置内容:


[RouterOS@ROSABC] ip address> export from=0,1
# dec/23/2003 13:25:30 by RouterOS 2.8beta12
# software id = MGJ4-MAN
#
/ ip address
add address=10.1.0.172/24 network=10.1.0.0 broadcast=10.1.0.255 \
interface=bridge1 comment="" disabled=no
add address=10.5.1.1/24 network=10.5.1.0 broadcast=10.5.1.255 \
interface=ether1 comment="" disabled=no

[RouterOS@ROSABC] ip address>

导入指令

操作路径:/import

import 命令只能在根目录下使用/import file_name 指令还原指定配置。这种方式适用于部分配置或者功能,例如 ip firewall filter、queue simple 等

指令描述

file=[filename] – 导入的路由器配置文件

例如:

使用下面的指令操作导入配置文件:


[RouterOS@ROSABC] > import address.rsc
Opening script file address.rsc Script file loaded successfully
[RouterOS@ROSABC] >

Winbox 里可以查看生产的.rsc 的文件:
游客,如果您要查看本帖隐藏内容请回复


系统复位

操作路径:/system> reset-configuration

这个指令将会清除掉路由器的所有配置,包括登陆的账号和密码(恢复为“admin“和空密码)IP 地址和其他配置将会被抹

去,在 reset 指令执行后路由器将会重启。RouterOS v3.x 后版本,在复位后默认的 ether1 接口 IP 地址将设置为

192.168.88.1/24

例如:


[admin@Office] /system> reset-configuration
Dangerous! Reset anyway-- [y/N]: y

发表于 2013-4-30 14:58:54 | 显示全部楼层
ROS软路由论坛
导出指令(Export
发表于 2013-4-30 12:35:58 | 显示全部楼层
sdafsdfsadfsdfsadf
发表于 2013-4-26 09:36:58 | 显示全部楼层
非常有用学习了
发表于 2013-5-2 22:46:27 | 显示全部楼层
沙发,板凳都没偶的份了。
发表于 2013-4-27 23:59:50 | 显示全部楼层
我也来学习一下,谢谢了
发表于 2013-5-28 02:31:54 | 显示全部楼层
学习学习!!!!!!!!!!
发表于 2013-5-28 09:36:36 | 显示全部楼层
wrerfewrewtrewtretret
发表于 2013-5-28 09:39:00 | 显示全部楼层
see see see see what content
发表于 2013-8-25 01:59:34 | 显示全部楼层
支持一下。。。
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

ROS教程版块已全面开放,
即使是新注册的初级会员也可阅读全部内容。

不良信息举报Q:2000617

不良信息举报Q:2000617|Archiver|小黑屋|ROS软路由论坛 ROSABC.com

GMT+8, 2020-8-7 04:27 , Processed in 0.319196 second(s), 23 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表