ROS软路由论坛 ROSABC.com

 找回密码
 会员注册
查看: 7859|回复: 73

[VPN虚拟私有网络] [点对点的 SSTP] 下面一个事例两个企业内网采用基于 SSTP 隧

  [复制链接]
发表于 2013-4-21 04:27:29 | 显示全部楼层 |阅读模式
ROS软路由论坛
点对点的 SSTP

下面一个事例两个企业内网采用基于 SSTP 隧道连接,考虑下面的网络:

游客,如果您要查看本帖隐藏内容请回复


Office 和 Home 路由器连接互联网通过 ether1,内网主机连接到 ether2,两个内网他们不在同一广播域,如 果两个内网需要在同样广播域内,你需要使用 BCP,并桥接 SSTP 隧道与本地网卡

首先创建一个用户账号


[admin@RemoteOffice] /ppp secret> add name=Home service=sstp password=123
local-address=172.16.1.1 remote-address=172.16.1.2 routes="10.1.202.0/24 172.16.1.2 1"
[admin@RemoteOffice] ppp secret> print detail
Flags: X - disabled
0 name="Home" service=sstp caller-id="" password="123" profile=default
local-address=172.16.1.1 remote-address=172.16.1.2 routes=="10.1.101.0/24 172.16.1.1
1"

[admin@RemoteOffice] /ppp secret>

注意:无论什么时候我们设置 SSTP 客户端添加路由,如果这个选项没有设置,你将需要指定静态路由配置在两 个路由器上.

接下来启用 SSTP 服务器在 Office 路由器,并在 Home 路由器配置 SSTP 客户端


[admin@RemoteOffice] /interface sstp-server server> set certificate=server
[admin@RemoteOffice] /interface sstp-server server> set enabled=yes
[admin@RemoteOffice] /interface sstp-server server> print
enabled: yes port: 443
max-mtu: 1500 max-mru: 1500
mrru: disabled keepalive-timeout: 60
default-profile: default certificate: server
require-client-certificate: no

authentication: pap,chap,mschap1,mschap2

在 Home 路由器配置 SSTP 客户端


[admin@Home] /interface sstp-client> add user=Home password=123 connect-to=192.168.80.1 disabled=no

[admin@Home] /interface sstp-client> print
Flags: X - disabled, R - running
0 R name="sstp-out1" max-mtu=1500 max-mru=1500 mrru=disabled connect-to=192.168.80.1:443 user="Home" password="123" proxy=0.0.0.0:443 profile=default certificate=none keepalive-timeout=60 add-default-route=no dial-on-demand=no authentication=pap,chap,mschap1,mschap2

[admin@Home] /interface sstp-client>

现在我们我们需要添加静态路由在 Home 路由器上,用于查找在 Office 路由后的网络


[admin@Home] /ip route> add dst-address=10.1.101.0/24 gateway=172.16.1.1

在隧道建立后你可以 ping 通远端的网络。

发表于 2013-9-1 07:40:38 | 显示全部楼层
ROS软路由论坛
很不错  很实用的东西  谢谢!
发表于 2013-8-30 17:05:42 | 显示全部楼层
谢谢,我是来学习的小马甲
发表于 2013-8-25 16:53:39 | 显示全部楼层
发表于 2013-6-26 09:34:04 | 显示全部楼层
SEE SEE SEE SEE SEE WHAT
发表于 2013-8-18 09:16:49 | 显示全部楼层
看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款看看看看看阿奎那看看啊看看阿卡娜卡卡哪款
发表于 2013-7-1 11:39:11 | 显示全部楼层
lai xuexixia,kankan
发表于 2013-6-29 11:28:30 | 显示全部楼层
学习一下
发表于 2013-6-30 23:56:31 | 显示全部楼层
看看...............
发表于 2013-6-26 00:48:54 | 显示全部楼层
WEFWEQEWFVERFEFQEF
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

ROS教程版块已全面开放,
即使是新注册的初级会员也可阅读全部内容。

网站合作Q:2000617 点击留言

网站合作Q:2000617|Archiver|小黑屋|ROS软路由论坛 ROSABC.com

GMT+8, 2019-11-17 10:22 , Processed in 0.236154 second(s), 23 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表