ROS软路由论坛 ROSABC.com

 找回密码
 会员注册
查看: 3847|回复: 12

[Default默认分类] [计划任务配置] 计划任务列表能触发脚本执行,在指定的时

[复制链接]
发表于 2013-4-21 05:08:44 | 显示全部楼层 |阅读模式
ROS软路由论坛
Scheduler(计划任务)

设定的计划任务,并通过时间安排执行相应的脚本操作.

规格

功能包需求: system

等级需求: Level1



操作路径: /system scheduler
=============================
计划任务配置

计划任务列表能触发脚本执行,在指定的时间段或者是在指定的时间间隔。 属性描述

interval (时间; 默认: 0s) - 脚本执行的间隔时间,脚本反复执行在一个指定的时间间隔

name (名称) – 任务名

on-event (名称) – 脚本执行名。通过调用/system script 里的脚本规则名称

run-count (只读: 整型) – 监视脚本使用数, 这个计数器记录当每个脚本执行一次,计数器便增加 1

start-date (日期) – 开始脚本执行的日期

start-time (时间) – 开始脚本执行的时间

startup – 默认在系统启动 3 秒后执行脚本.

注:重启路由器时将重置 run-count 计数器。

如果计划表选项里面对 start-time 设置了 startup,则在控制台开启后 3 秒运行。这意味着所有的脚本设置为start-time=startup 和 interval=0,当路由器启动就会被执行。

事例 1:我们添加一个任务执行系统日志记录测试,并间隔 1 小时执行一次,这个操作为 logtest:


[RouterOS@ROSABC] system script> add name=logtest source=:log info “test”
[RouterOS@ROSABC] system script> print
0 name="script1" owner="admin" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff
last-started=may/16/2008 21:32:51 run-count=3 source=:log info " test"
[RouterOS@ROSABC] system script> .. scheduler

[RouterOS@ROSABC] system scheduler> add name=run-1h interval=1h on-event=logtest

[RouterOS@ROSABC] system scheduler> print
Flags: X - disabled
# NAME ON-EVENT START-DATE START-TIME INTERVAL RUN-COUNT
0 run-1h logtest mar/30/2004 06:11:35 1h 0
[RouterOS@ROSABC] system scheduler>

Schedule 在 Winbox 的配置如下:
游客,如果您要查看本帖隐藏内容请回复



事例 2:另外一个例子是添加 2 个脚本改变带宽设置队列规则”cust0”,每天上午 9 点限制为 64kb/s,下午5 点限制为 128kb/s。这个队列的规则、脚本和计划任务如下(注:在 2.9 种 cust0 是不需要加双引号的,但在3.0 中需要注明字符串,要加上双引号”cust0”) :


[RouterOS@ROSABC] queue simple> add name=Cust0 interface=ether1 \
\... target-address=192.168.0.0/24 limit-at=64000
[RouterOS@ROSABC] queue simple> print
Flags: X - disabled, I - invalid
0 name="Cust0" target-address=192.168.0.0/24 dst-address=0.0.0.0/0 interface=ether1 limit-at=64000 queue=default priority=8 bounded=yes

[RouterOS@ROSABC] queue simple> /system script

[RouterOS@ROSABC] system script> add name=start_limit source={/queue simple set \



\... “Cust0” limit-at=64000}

[RouterOS@ROSABC] system script> add name=stop_limit source={/queue simple set \
\... “Cust0” limit-at=128000}
[RouterOS@ROSABC] system script> print
0 name="start_limit" source="/queue simple set “Cust0” limit-at=64000" owner=admin run-count=0
1 name="stop_limit" source="/queue simple set “Cust0” limit-at=128000" owner=admin run-count=0

[RouterOS@ROSABC] system script> .. scheduler

[RouterOS@ROSABC] system scheduler> add interval=24h name="set-64k" \
\... start-time=9:00:00 on-event=start_limit

[RouterOS@ROSABC] system scheduler> add interval=24h name="set-128k" \
\... start-time=17:00:00 on-event=stop_limit
[RouterOS@ROSABC] system scheduler> print Flags: X - disabled
# NAME ON-EVENT START-DATE START-TIME INTERVAL RUN-COUNT
0 set-64k start... oct/30/2008 09:00:00 1d 0
1 set-128k stop_... oct/30/2008 17:00:00 1d 0
[RouterOS@ROSABC] system scheduler>

事例 3:下面的例子安排了一个通过电子邮件发送每周备份路由器配置信息的脚本:


[RouterOS@ROSABC] system script> add name=e-backup source={/system backup save name=email; /tool e-mail send to="root@host.com" subject=([/system
{... identity get name] . " Backup") file=email.backup}
[RouterOS@ROSABC] system script> print
0 name="e-backup" source="/system backup save name=ema... owner=admin run-count=0

[RouterOS@ROSABC] system script> .. scheduler

[RouterOS@ROSABC] system scheduler> add interval=7d name="email-backup" \
\... on-event=e-backup

[RouterOS@ROSABC] system scheduler> print
Flags: X - disabled
# NAME ON-EVENT START-DATE START-TIME INTERVAL RUN-COUNT
0 email-... e-backup oct/30/2008 15:19:28 7d 1
[RouterOS@ROSABC] system scheduler>

不要忘记去设置电子邮件参数,即 SMTP 服务的配置,操作路径/tool e-mail 例如(注:建议是自己的 SMTP服务器,一些正规网站的邮件服务器可能会将发送信息屏蔽):


[RouterOS@ROSABC] tool e-mail> set server=159.148.147.198 from=SysAdmin@host.com

[RouterOS@ROSABC] tool e-mail> print server: 159.148.147.198
from: SysAdmin@host.com

[RouterOS@ROSABC] tool e-mail>

事例 4

下面的例子是从午夜 12 点到正午 12 点的每个小时里把“x”加进日志中:


[RouterOS@ROSABC] system script> add name=enable-x source={/system scheduler
{... enable x}

[RouterOS@ROSABC] system script> add name=disable-x source={/system scheduler
{... disable x}

[RouterOS@ROSABC] system script> add name=log-x source={:log info “x”}
[RouterOS@ROSABC] system script> .. scheduler

[RouterOS@ROSABC] system scheduler> add name=x-up start-time=00:00:00 \
\... interval=24h on-event=enable-x

[RouterOS@ROSABC] system scheduler> add name=x-down start-time=12:00:00
\... interval=24h on-event=disable-x

[RouterOS@ROSABC] system scheduler> add name=x start-time=00:00:00 interval=1h \
\... on-event=log-x

[RouterOS@ROSABC] system scheduler> print
Flags: X - disabled
# NAME ON-EVENT START-DATE START-TIME INTERVAL RUN-COUNT
0 x-up enable-x oct/30/2008 00:00:00 1d 0
1 x-down disab... oct/30/2008 12:00:00 1d 0
2 x log-x oct/30/2008 00:00:00 1h 0
[RouterOS@ROSABC] system scheduler>

发表于 2013-5-15 13:50:13 | 显示全部楼层
ROS软路由论坛
好,,,,,顶
发表于 2013-5-16 09:48:51 | 显示全部楼层
很好,很实用
发表于 2013-5-25 01:28:22 | 显示全部楼层
发表于 2013-8-9 16:59:04 | 显示全部楼层
see  see  see  see
发表于 2013-8-15 13:23:06 | 显示全部楼层
我要学习

发表于 2013-9-3 15:04:17 | 显示全部楼层
谢谢分享...谢谢分享...
发表于 2013-11-9 10:36:10 | 显示全部楼层
这个必须学习......我来啦。。
发表于 2013-12-25 10:53:33 | 显示全部楼层
这个必须学习......我来啦。。
发表于 2017-11-24 09:02:45 | 显示全部楼层
很好,很实用
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

ROS教程版块已全面开放,
即使是新注册的初级会员也可阅读全部内容。

网站合作Q:2000617 点击留言

网站合作Q:2000617|Archiver|小黑屋|ROS软路由论坛 ROSABC.com

GMT+8, 2019-10-16 00:13 , Processed in 0.125613 second(s), 23 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表