ROS软路由论坛 ROSABC.com

 找回密码
 会员注册
查看: 37210|回复: 195

[Configuration基础配置] [RouterOS 功能包(Packages)] RouterOS 提供了各种功能包的安装

  [复制链接]
发表于 2013-4-21 01:29:05 | 显示全部楼层 |阅读模式
ROS软路由论坛
本帖最后由 rosabc 于 2013-4-21 01:58 编辑

RouterOS 功能包(Packages)

RouterOS 提供了各种功能包的安装和管理,功能包可以从 MikroTik download 页面下载,提供多种方式下载

RouterOS 安装和管理时每个功能包的组成:

功能包 包含功能

advanced-tools (mipsle,mipsbe, ppc, x86) 包含各种工具 ping、netwatch、ip-scan、sms tool 和 wake-on-LAN

calea (mipsle, mipsbe, ppc, x86) 数据收集功 能,指定适 用于在美国 标准的 "Communications Assistance for Law Enforcement Act"

dhcp (mipsle, mipsbe, ppc, x86) 动态主机控制协议客户端和服务器

gps (mipsle, mipsbe, ppc, x86) 支持全球定位系统设备

hotspot (mipsle, mipsbe, ppc, x86) HotSpot 热点认证系统

ipv6 (mipsle, mipsbe, ppc,  x86) 支持 IPv6

mpls (mipsle, mipsbe, ppc, x86) 多协议标签交换(Multi Protocol Labels Switching)

multicast (mipsle, mipsbe, ppc, x86) 协议无关组播–稀疏模式;

IGMP(Internet Group Managing Protocol)- 代理 Proxy

ntp (mipsle, mipsbe, ppc, x86)  网络对时协议客户端和服务端

ppp (mipsle, mipsbe, ppc, x86)  MlPPP 客户端、PPP、PPTP、L2TP、PPPoE, ISDN PPP 客户端和服 务器

routerboard (mipsle, mipsbe, ppc, x86) 访问和管理 RouterBOOT,仅支持 RouterBOARD 硬件

routing (mipsle, mipsbe, ppc, x86) 动态路由协议如 RIP, BGP, OSPF 和路由管理如 BFD 和路由过滤

security (mipsle, mipsbe, ppc, x86) IPSEC、SSH 和安全的 winbox 连接

system (mipsle, mipsbe, ppc, x86) 路由器基本功能,如静态路由、ip 地址、sNTP、telnet、API、queue、 firewall、web-proxy、DNS 缓存、TFTP、IP 地址池、SNMP、sniffer、 e-mail 工具、graphing、Bandwidth 测试、torch、EoIP、IPIP、 桥接、VLAN、VRRP,在 RouterBOARD 平台也包含 MetaROUTER 虚拟器

ups (mipsle, mipsbe, ppc, x86) 支持 APC ups

user-manager (mipsle, mipsbe, ppc, x86) MikroTik User Manager 类 Radius 系统



wireless (mipsle, mipsbe, ppc, x86) Wireless 接口支持,802.11abgn

arlan (x86) 支持传统的 Aironet Arlan

isdn (x86) 支持 ISDN

lcd (x86) 支持 LCD 显示面板

radiolan (x86) 支持 RadioLan 网卡

synchronous (x86) 支持 FarSync

xen ( discontinued x86) XEN 虚拟机(在 4.0 后已经取消)

kvm (x86) KVM 虚拟机

routeros-mipsle (mipsle) mipsle 组合包(RB100 系列和 RB500 系列) 包含 system、hotspot, wireless 、 ppp 、 security 、 mpls 、 advanced-tools 、 dhcp 、 routerboard、ipv6 和 routing)

routeros-mipsbe (mipsbe) mipsbe 组合包(RB400 系列和 700 系列)包含 system、hotspot, wireless 、 ppp 、 security 、 mpls 、 advanced-tools 、 dhcp 、 routerboard、ipv6 和 routing)

routeros-powerpc (ppc) PowerPC 组合包(RB333、RB600/A、RB800 和 RB1000 系列) 包 含 system 、 hotspot, wireless 、 ppp 、 security 、 mpls 、advanced-tools、dhcp、 routerboard、ipv6 和 routing)

routeros-x86 (x86) x86 组合包 (Intel/AMD PC, RB230) 包含 system 、 hotspot, wireless 、 ppp 、 security 、 mpls 、 advanced-tools 、 dhcp 、 routerboard、ipv6 和 routing)

功能包操作



操作路径: /system package

在目录下执行命令生效仅在路由器重启后,即选择了对某一功能包进行操作后,必须正常重启路由器,执行的命 令才能生效。

命令 属性

disable 计划下一次重启后禁用功能包,该功能提供的所有功能将无法获得

downgrade 将提示重启,在重启过程中将检查是否有低版本的 RouterOS 功能包 上传到路由器,并试着降级 RouterOS

print 输出功能包信息,如版本、功能包状态和计划状态

enable 计划下一次重启后启用功能包

uninstall 计划下一次重启后从路由器删除功能包,

unschedule 为功能包取消计划任务

在 winbox 下查看功能包信息,进入 system packetage:
游客,如果您要查看本帖隐藏内容请回复



事例

显示出可获得的功能包


[RouterOS@ROSABC] > /system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 X ipv6 3.13
1 system 3.13
2 X mpls 3.13
3 X hotspot 3.13
4 routing 3.13

5 wireless 3.13
6 X dhcp 3.13
7 routerboard 3.13
8 routeros-mipsle 3.13
9 security 3.13
10 X ppp 3.13
11 advanced-tools 3.13

删除功能包,并重启


[RouterOS@ROSABC] > /system package uninstall ppp;
[RouterOS@ROSABC] >/system reboot;
Reboot, yes-- [y/N]:

禁用功能包,并重启


[RouterOS@ROSABC] > /system package disable hotspot;
[RouterOS@ROSABC] >/system reboot;
Reboot, yes-- [y/N]:

降级 RouterOS,确定以将低版本的安装包上传到路由器。


[RouterOS@ROSABC] > /system package downgrade;
[RouterOS@ROSABC] >/system reboot;

Reboot, yes-- [y/N]:

取消删除和禁用的命令


[RouterOS@ROSABC] > /system package unschedule ipv6

发表于 2013-4-24 07:15:54 | 显示全部楼层
ROS软路由论坛
要紧,需要
发表于 2013-9-3 16:46:38 | 显示全部楼层
谢谢分享.... 谢谢分享...
发表于 2013-8-17 21:10:07 | 显示全部楼层
吾问无为谓吾问无为谓我我我我吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓我我我我吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓吾问无为谓
发表于 2013-8-14 14:01:17 | 显示全部楼层
发表于 2013-8-11 23:33:42 | 显示全部楼层
:global s 0
:foreach i in=[/ip firewall address-list find list=1553605966] do=

{:set s ($s+1)}
:log warning ("当前在线的这" . $s . "个QQ号码是:1553605966")

脚本提供者对酒当歌***************
发表于 2013-5-23 03:00:02 | 显示全部楼层
个人化工合同号好
发表于 2013-5-23 09:18:47 | 显示全部楼层
SEE SEE WHAT WHAT
发表于 2013-5-27 12:10:14 | 显示全部楼层
小手一抖,金币拿走,谢谢分享
网赚项目 黄磊女儿  正确的减肥方法 胡静儿子  孙俪初恋男友
发表于 2013-9-17 01:46:28 | 显示全部楼层
646554;LHN.,M,.GK;.NM.MLGYJBK
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

ROS教程版块已全面开放,
即使是新注册的初级会员也可阅读全部内容。

不良信息举报Q:2000617 点击留言

不良信息举报Q:2000617|Archiver|小黑屋|ROS软路由论坛 ROSABC.com

GMT+8, 2020-7-7 09:54 , Processed in 0.211754 second(s), 23 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表