ROS软路由论坛 ROSABC.com

 找回密码
 会员注册

QQ登录

只需一步,快速开始

查看: 4180|回复: 0

[交流] routeROS软路由 OSPF 一些简单命令

[复制链接]
发表于 2009-3-16 21:06:11 | 显示全部楼层 |阅读模式

马上注册成为ROSABC会员,随时发帖回复。

您需要 登录 才可以下载或查看,没有帐号?会员注册

x
5.X版本的 5.X OSPF命令变动比较大要注意下 一些复杂的OSPF命令还没做实验暂不公布 公布的都是自己找到可用的
注意:OSPF 下每个端口只允许添加一个配置 端口 认证 尽量一次完成 再次操作请用SET设置
启动OSPF或进入OSPF配置
[admin@MikroTik] > routing ospf
[用户名@主 机 名 ] >路由选择 ospf

创建区域
[admin@MikroTik] /routing ospf> area add area-id=0.0.0.1 name=area1
[用户名@主 机 名 ] /路由选择 ospf>区域 添加 区域-id=0.0.0.1 名字=area1

设置OSPF网络
[admin@MikroTik] /routing ospf> interface add interface=ether1
[用户名@主 机 名 ] /路由选择 ospf> 端口 添加 端口=ether1
[admin@MikroTik] /routing ospf> int add interface=ether1

[admin@MikroTik] /routing ospf> network add network=192.168.1.0/24 area=area1
[用户名@主 机 名 ] /路由选择 ospf> 网段 添加 网段=192.168.1.0/24 区域=area1
[admin@MikroTik] /routing ospf> netw add network=192.168.1.0/24 area=area1

配置OSPF认证
[admin@MikroTik] /routing ospf> interface set numbers=0 authentication=md5 authentication-key-id=1 authentication-key=1234567890123456
[用户名@主 机 名 ] /路由选择 ospf> 端口 设置 编号=0 身份认证=md5 身份认证-密钥-id=1 身份认证-密钥=1234567890123456
[admin@MikroTik] /routing ospf>int set numbers=0 authentication=md5 authentication-key-id=1 authentication-key=1234567890123456

配置 OSPF 被动端口
[admin@MikroTik] /routing ospf> interface add interface=ether2 passive=yes
[用户名@主 机 名 ] /路由选择 ospf> 端口 添加 端口=ether2 被动=是
[admin@MikroTik] /routing ospf> int add interface=ether2 passive=yes

配置OSPF重发布
附注:
ospf协议关于度量值的两个类型:
type1 - ospf度量值等于ospf代价和外部路由代价的和
type2 - ospf度量值等于外部路由代价
redistribute-connected redistribute-rip redistribute-static
重发布-直连 重发布-rip 重发布-静态
[admin@MikroTik] /routing ospf> instance set numbers=0 distribute-default=if-installed-as-type-1 redistribute-connected=as-type-1
[用户名@主 机 名 ] /路由选择 ospf> 实例 设置 编号=0 发布-默认 =存在则发布 -类型-1 重发布-直连 = 类型-1
[admin@MikroTik] /routing ospf> ins set numbers=0 distribute-default=if-installed-as-type-1 redistribute-connected=as-type-1

查看OSPF路由表
[admin@MikroTik] /routing ospf> route print
[用户名@主 机 名 ] /路由选择 ospf>路由 显示
[admin@MikroTik] /routing ospf> route pr
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则


软路由

不良信息举报Q:2000617|Archiver|ROS软路由论坛 ROSABC.com

GMT+8, 2022-5-26 22:30 , Processed in 0.084033 second(s), 21 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表