ROS软路由论坛 ROSABC.com

 找回密码
 会员注册

QQ登录

只需一步,快速开始

查看: 6353|回复: 1

[交流] ROS软路由 RIP命令 其实- -是自己笔记了附赠思科笔记

[复制链接]
发表于 2007-9-16 01:35:29 | 显示全部楼层 |阅读模式

马上注册成为ROSABC会员,随时发帖回复。

您需要 登录 才可以下载或查看,没有帐号?会员注册

x
注意:RIP下每个端口只允许添加一个配置 版本 认证 尽量一次完成 再次操作请用SET设置
启动RIP或进入RIP配置
[admin@MikroTik] > routing rip
[用户名@主 机 名 ] >路由选择 rip

设置RIP网络
[admin@MikroTik] /routing rip> interface add interface=ether1 receive=v2 send=v2
[用户名@主 机 名 ] /路由选择 rip> 端口 添加 端口=ether1 接收=v2 发送=v2
[admin@MikroTik] /routing rip> int add interface=ether1 receive=v2 send=v2

[admin@MikroTik] /routing rip> network add network=192.168.1.0/24
[用户名@主 机 名 ] /路由选择 rip> 网络 添加 网络=192.168.1.0/24
[admin@MikroTik] /routing rip> netw add network=192.168.1.0/24

配置RIP认证
[admin@MikroTik] /routing rip> interface set numbers=0 authentication=md5 authentication-key=1234567890123456
[用户名@主 机 名 ] /路由选择 rip> 端口 设置 编号=0 身份认证=md5 身份认证-密钥=1234567890123456
[admin@MikroTik] /routing rip> int set numbers=0 authentication=md5 authentication-key=1234567890123456

配置RIP被动端口
[admin@MikroTik] /routing rip> interface add interface=ether2 passive=yes
[用户名@主 机 名 ] /路由选择 rip> 端口 添加 端口=ether2 被动=是
[admin@MikroTik] /routing rip> int add interface=ether2 passive=yes

配置RIP重发布
附注:redistribute-connected redistribute-ospf redistribute-static
重发布-直连 重发布-ospf 重发布-静态
[admin@MikroTik] /routing rip> set distribute-default=if-installed redistribute-connected=yes
[用户名@主 机 名 ] /路由选择 rip> 设置 发布-默认 =存在则发布 重发布-直连 =是

查看RIP路由表
[admin@MikroTik] /routing rip> route print
[用户名@主 机 名 ] /路由选择 rip> 路由 显示
[admin@MikroTik] /routing rip> route pr

以下是思科的
启动RIP或进入RIP配置
Router_config#router rip
主机名_全局模式#路由器 rip

设置RIP网络
Router_config_rip#network 192.168.1.0 255.255.255.0
主机名_全局模式_rip# 网络 192.168.1.0 255.255.255.0
Router_config_rip#netw 192.168.1.0 255.255.255.0

Router_config_rip#version 2
主机名_全局模式_rip#版本 2
Router_config_rip#ver 2

配置RIP认证
Router_config_f0/0#ip rip authentication md5
主机名_全局模式_端口#ip rip 身份认证 md5
Router_config_f0/0#ip rip auth md5

Router_config_f0/0#ip rip md5-key 1 md5 1234567890123456
主机名_全局模式_端口#ip rip md5-密钥 1 md5 1234567890123456
Router_config_f0/0#ip rip md5 1 md5 1234567890123456

配置RIP被动端口
Router_config_f0/3#ip rip passive
主机名_全局模式_端口#ip rip 被动

配置RIP重发布
附注:connect ospf static
直连 ospf 静态
Router_config_rip#redistribute connect
主机名_全局模式_rip# 重发布 直连

查看RIP路由表
Router_config#show ip rip database
主机名_全局模式#显示 ip rip 数据库
Router_config#show ip rip da

启动OSPF或进入OSPF配置
Router_config#router ospf 1
主机名_全局模式#路由器 ospf 进程

设置OSPF网络
Router_config_ospf_1#network 192.168.1.0 255.255.255.0 area 0
主机名_全局模式 _ospf_1# 网络 192.168.1.0 255.255.255.0 区域 0
Router_config_ospf_1#netw 192.168.1.0 255.255.255.0 ar 0

配置OSPF认证
Router_config_f0/0#ip ospf authentication md5
主机名_全局模式_端口#ip ospf 身份认证 md5
Router_config_f0/0#ip ospf auth md5

Router_config_f0/0#ip ospf md5-key 1 md5 1234567890123456
主机名_全局模式_端口#ip ospf md5-密钥 1 md5 1234567890123456
Router_config_f0/0#ip ospf md5 1 md5 1234567890123456

配置OSPF被动端口
Router_config_f0/3#ip ospf passive
主机名_全局模式_端口#ip ospf 被动

配置OSPF重发布
附注:connect ospf static
直连 ospf 静态
Router_config_ospf#redistribute connect
主机名_全局模式_ospf# 重发布 直连

配置OSPF发布默认路由
Router_config_ospf_1#default-information originate
主机名_全局模式_ospf_进程#缺省信息发布 生成缺省路由
Router_config_ospf_1#default-in orig

查看OSPF路由表
Router_config#show ip ospf database
主机名_全局模式#显示 ip ospf 数据库
Router_config#show ip ospf da

静态路由的两种方法
Router_config#ip route 192.168.2.0 255.255.255.0 192.168.1.1
主机名_全局模式#ip 路由 目的网段 目的IP掩码 网关

Router_config#ip route 192.168.2.0 255.255.255.0 fastEthernet 0/0
主机名_全局模式#ip 路由 目的网段 目的IP掩码 快速以太网端口 0/0

浮动路由
Router_config#ip route 192.168.2.0 255.255.255.0 192.168.1.1 10
主机名_全局模式#ip 路由 目的网段 目的IP掩码 网关 管理距离

缺省路由的两种方法
Router_config#ip route 0.0.0.0 0.0.0.0 192.168.1.1
主机名_全局模式#ip 路由 任何网段 网关

Router_config#ip route default 192.168.1.1
主机名_全局模式#ip 路由 缺省 网关
Router_config#ip route de 192.168.1.1

MSTP思科的 ROS软路由还没时间做
多实例MSTP
DCRS-5950-28T(config)#spanning-tree
DCRS-5950-28T(config)#生成树协议
DCRS-5950-28T(config)#sp

DCRS-5950-28T(config)#spanning-tree mst configuration
DCRS-5950-28T(config)#生成树协议 mst 域设置
DCRS-5950-28T(config)#sp mst con

DCRS-5950-28T(config-mstp-region)#name test
DCRS-5950-28T(config-mstp-region)#域名 名字

DCRS-5950-28T(config-mstp-region)# instance 1 vlan 10;20
DCRS-5950-28T(config-mstp-region)# 实例 1 vlan 10;20
DCRS-5950-28T(config-mstp-region)#ins 1 vlan 10;20

DCRS-5950-28T(config-mstp-region)# instance 2 vlan 30;40
DCRS-5950-28T(config-mstp-region)# 实例 2 vlan 30;40
DCRS-5950-28T(config-mstp-region)#ins 2 vlan 30;40

DCRS-5950-28T(config)#spanning-tree mst 1 priority 4096
DCRS-5950-28T(config)#生成树协议 mst实例 ID 优先级 4096
DCRS-5950-28T(config)#sp mst 1 pr 4096

DCRS-5950-28T(config)#spanning-tree mst 2 priority 8192
DCRS-5950-28T(config)#生成树协议 mst实例 ID 优先级 8192
DCRS-5950-28T(config)#sp mst 2 pr 8192
- -PS:对了ROS软路由好像不支持MSTP


IPSEC的- - 不过思科IPSEC 命令有问题 手动配置中不会出现变换 他们为了省事居然把安全关联一束写成变换压力
发表于 2007-9-19 05:33:43 | 显示全部楼层
订- -没人看压力
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则


软路由

不良信息举报Q:2000617|Archiver|ROS软路由论坛 ROSABC.com

GMT+8, 2022-5-26 21:59 , Processed in 0.073593 second(s), 22 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表