ROS软路由论坛 ROSABC.com

 找回密码
 会员注册
查看: 212|回复: 3

[原创] 多拨方法

[复制链接]
发表于 2019-9-16 10:55:39 | 显示全部楼层 |阅读模式
ROS软路由论坛
最近刚买了个ros路由 hap ac2 研究ros多拨

通过对网上的vrrp测试 发现我这边网络一直拨不上(只能同时拨成功一次),无意间发现新建pppoe client客户端,输入账号密码其他保持默认,直接拨成功了,还很稳定
然后就根据网上教程 编辑了下脚本
此脚本只包含 mangle配置和nat伪装

此外还需在ip->router添加 多拨次数的 标记 (脚本不会写,可以去YouTube看比尔麦克的一线多拨最稳教程)

脚本使用方法:system->scripts->add new->粘贴保存 执行一次
脚本如下:192.168.88.0为lan口ip 这里是10拨的
/ip firewall mangle
add action=mark-connection chain=prerouting dst-address-type=!local \
new-connection-mark=PCC1 passthrough=yes per-connection-classifier=\
both-addresses:10/0 src-address=192.168.88.0/24
add action=mark-connection chain=prerouting dst-address-type=!local \
new-connection-mark=PCC2 passthrough=yes per-connection-classifier=\
both-addresses:10/1 src-address=192.168.88.0/24
add action=mark-connection chain=prerouting dst-address-type=!local \
new-connection-mark=PCC3 passthrough=yes per-connection-classifier=\
both-addresses:10/2 src-address=192.168.88.0/24
add action=mark-connection chain=prerouting dst-address-type=!local \
new-connection-mark=PCC4 passthrough=yes per-connection-classifier=\
both-addresses:10/3 src-address=192.168.88.0/24
add action=mark-connection chain=prerouting dst-address-type=!local \
new-connection-mark=PCC5 passthrough=yes per-connection-classifier=\
both-addresses:10/4 src-address=192.168.88.0/24
add action=mark-connection chain=prerouting dst-address-type=!local \
new-connection-mark=PCC6 passthrough=yes per-connection-classifier=\
both-addresses:10/5 src-address=192.168.88.0/24
add action=mark-connection chain=prerouting dst-address-type=!local \
new-connection-mark=PCC7 passthrough=yes per-connection-classifier=\
both-addresses:10/6 src-address=192.168.88.0/24
add action=mark-connection chain=prerouting dst-address-type=!local \
new-connection-mark=PCC8 passthrough=yes per-connection-classifier=\
both-addresses:10/7 src-address=192.168.88.0/24
add action=mark-connection chain=prerouting dst-address-type=!local \
new-connection-mark=PCC9 passthrough=yes per-connection-classifier=\
both-addresses:10/8 src-address=192.168.88.0/24
add action=mark-connection chain=prerouting dst-address-type=!local \
new-connection-mark=PCC10 passthrough=yes per-connection-classifier=\
both-addresses:10/9 src-address=192.168.88.0/24

add action=mark-routing chain=prerouting connection-mark=PCC1 \
new-routing-mark=R1 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=PCC2 \
new-routing-mark=R2 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=PCC3 \
new-routing-mark=R3 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=PCC4 \
new-routing-mark=R4 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=PCC5 \
new-routing-mark=R5 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=PCC6 \
new-routing-mark=R6 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=PCC7 \
new-routing-mark=R7 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=PCC8 \
new-routing-mark=R8 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=PCC9 \
new-routing-mark=R9 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=PCC10 \
new-routing-mark=R10 passthrough=yes src-address=192.168.88.0/24

add action=mark-connection chain=input in-interface=pppoe-out1 \
new-connection-mark=PCC1 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out2 \
new-connection-mark=PCC2 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out3 \
new-connection-mark=PCC3 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out4 \
new-connection-mark=PCC4 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out5 \
new-connection-mark=PCC5 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out6 \
new-connection-mark=PCC6 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out7 \
new-connection-mark=PCC7 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out8 \
new-connection-mark=PCC8 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out9 \
new-connection-mark=PCC9 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out10 \
new-connection-mark=PCC10 passthrough=yes

add action=mark-routing chain=output connection-mark=PCC1 new-routing-mark=R1 \
passthrough=yes
add action=mark-routing chain=output connection-mark=PCC2 new-routing-mark=R2 \
passthrough=yes
add action=mark-routing chain=output connection-mark=PCC3 new-routing-mark=R3 \
passthrough=yes
add action=mark-routing chain=output connection-mark=PCC4 new-routing-mark=R4 \
passthrough=yes
add action=mark-routing chain=output connection-mark=PCC5 new-routing-mark=R5 \
passthrough=yes
add action=mark-routing chain=output connection-mark=PCC6 new-routing-mark=R6 \
passthrough=yes
add action=mark-routing chain=output connection-mark=PCC7 new-routing-mark=R7 \
passthrough=yes
add action=mark-routing chain=output connection-mark=PCC8 new-routing-mark=R8 \
passthrough=yes
add action=mark-routing chain=output connection-mark=PCC9 new-routing-mark=R9 \
passthrough=yes
add action=mark-routing chain=output connection-mark=PCC10 new-routing-mark=R10 \
passthrough=yes


/ip firewall nat
add action=masquerade chain=srcnat


此外:路由器买来发现没时间折腾(带娃太辛苦了),刚买一周多 退款是退不了了,想要的可去闲鱼
https://market.m.taobao.com/app/idleFish-F2e/widle-taobao-rax/page-detail?wh_weex=true&wx_navbar_transparent=true&id=602662541920&ut_sk=1.XBClLDCTwKsDACe2MMz2oYaJ_12431167_1568602394910.Copy.detail.602662541920.1085975956&forceFlush=1





WechatIMG30.jpeg
 楼主| 发表于 2019-9-16 10:57:43 | 显示全部楼层
ROS软路由论坛
更正一处 192.168.88.1为lan口ip 路由器已被我拔电重置了 没有图 见谅
 楼主| 发表于 2019-9-17 18:01:43 | 显示全部楼层
更新下购买链接 https://market.m.taobao.com/app/idleFish-F2e/widle-taobao-rax/page-detail?wh_weex=true&wx_navbar_transparent=true&id=602623448238&ut_sk=1.XBClLDCTwKsDACe2MMz2oYaJ_12431167_1568713758493.Copy.detail.602623448238.1085975956&forceFlush=1

比尔麦克:https://www.youtube.com/watch?v=e_zHWBIN5b8  空降到19:20处添加
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

ROS教程版块已全面开放,
即使是新注册的初级会员也可阅读全部内容。

网站合作Q:2000617 点击留言

网站合作Q:2000617|Archiver|小黑屋|ROS软路由论坛 ROSABC.com

GMT+8, 2019-10-24 09:35 , Processed in 0.140122 second(s), 21 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表