ROS软路由论坛 ROSABC.com

 找回密码
 会员注册
查看: 2513|回复: 4

ros常用命令

[复制链接]
发表于 2017-6-29 17:39:41 | 显示全部楼层 |阅读模式
ROS软路由论坛
/sy reset                        恢复路由原始状态
/sy reboot                      重启路由
/sy showdown                      关机
/sy ide set name=机器名      设置机器名
/export                        查看配置
/ip export                      查看IP配置
/sy backup 回车
save name=你要设置文件名              备份路由
LOAD NAME=你要设置文件名             恢复备份
/interface print                  查看网卡状态
0 X ether1 ether 1500 这个是网卡没有开启
0 R ether1 ether 1500 这个是正常状态
/int en 0                      激活0网卡
/int di 0                      禁掉0网卡
/ip fir con print                  查看当前所有网络边接
/ip service set www port=81          改变www服务端口为81
/ip hotspot user add name=user1password=1 增加用户
Certificate----------证书管理
Driver---------------设备管理
File------------------当地路由器文件的存储
interface ------------接口配置
log ------------------系统记录
password ------------改变密码
ping ----------------发送,回送ICMP数据包
port -----------------串行端口
quit ----------------退出控制
radius---------------Radius客户机设置
redo------------------- Redopreviosly undone action
setup ----------------基本的系统设置
snmp -----------------SNMP 设置
special-login-----------专用的登陆用户
undo----------------- 取先前的效果
user-------------------用户管理
ip--------------------- IP 选项
queue ----------------------带宽管理
system------------------- 系统信息和有效的程序
tool----------------------- 诊断工具
export --------------------显示或保存导出的脚本那是用来恢复的
配置
[admin@MikroTik] >
[admin@MikroTik] ip>
accounting------------------------交通统计
address---------------------------地址管理
arp---------------------------ARP 进入管理
dns ------------------------DNS 设置
firewall ------------------防火墙管理
neighbor ---------------------邻居
packing ---------------------数据打包设定
pool -------------------------IP地址池
route----------------------- 路由管理
service ---------------------IP 服务
policy-routing ----------------路由政策
upnp -------------------------Universal 即插即用
vrrp------------------------虚拟路由沉余协议
socks----------------------SOCKS 版本4代理
hotspot--------------------HotSpot 管理
ipsec ------------------IP安全
web-proxy -----------------HTTP 代理
export------------------------显示或保存导出的脚本那是用来
interfaces---网络接口
wireless---无线网络
bridge---桥接
ppp-虚拟拨号
ports--端口
queues-限速
drivers-设备
system
files-文件
       备份/恢复
log--系统日志
snmp-snmp管理方式
users-用户
radius-radius管理
tools-工具
new terminal-命令方式
telnet--tlenet连接方式
password--修改密码
certificate---证书 哎,盗版
madk supout.rif 制作rif文件
manual--说明
isdn chanels--一线通方式
routing--路由
exit--退出
ip addr add addr=192.168.1.1/24 interface=ether1
ip addr add addr=58.213.126.58/30 interface=ether2
ip route add gateway=58.213.126.57
       外网
ip firewall nat add chain=srcnat src-address=192.168.1.0/24 action=masquerade
222.190.124.46
218。94。132。50天之骄傲
<此处字符重复过多!点击下方“编辑”进行修改。>
sys reset
__________________________________
addresses--ip地址
routers-路由表
pool-地址池
arp-帮定ip
vrrp-热备份
firewall-防火墙
socks-代理
upnp-自动端口映射
traffic flow-网络流量
accounting--合计
services--服务
packing-ros模块
neighbors--邻居ros用户
ip dns set primary-dns=202.103.224.68----设置DNS为202.103.224.68
(首选DNS服务器)  
ip dns set secondary-dns=59.51.78.211----设置DNS为202.103.224.68
(备用DNS服务器)     
Ip dns set-allow-remote-requests=yes----设置允许远程请求=是的
ip firewall--------IP防火墙
ip route add gateway=10.0.0.1------设置网关为10.0.0.1
ip firewallnat add chain=srcnat action=masqueradesrc-address=192.168.1.1/24---------------设置回流
proxy------------代理
dhcp client-dhcp客户端
dhcp server - dhcp服务
dhcp relay-dhcp转换
hospot-热点认证
telephony-电话
ipsec-ip隧道连接方式
web proxy web代理
system system system system system system
---------------------------------------------
identity---ros标示
clock-时间
resources-系统配置
license-注册信息
packages--安装包
auto upgrade-自动升级
logging--日志
history--历史日志
console---com控制台
scripts--脚本
scheduler--进程
watchdog--监视狗
reboot-从起
shutdown-关机
lcd-小液晶显示ros消息
ntp chient--ros时间客户端
ntp server---ros时间服务端 自动更新ros时间
health---ros情况
ups-ups电源,可持续电源,就是电瓶。汗~
tools tools tools tools tools tools
--------------------------------------
ping
macping 探测mac地址
traceroute---Tracert命令
bandwidth test-宽带测试
btest server--btest服务器
traffic monitor--数据报监视器
packet sniffer--数据报扫描
torch--察看客户机信息
mac server mac 服务器
graphing---曲线图
ip sacan--ip扫描
ping speed--ping 速度
flood ping --ping阻塞
netwatch--网络监视
max-mtu=1492 ---最大接收单元为1492
PPPOE/ADSL拨号:
1
  
2
  
interface pppoe-client add user=user password=onovps.com use-peer-dns=yes add-default-route=yes\
  
max-mtu=1492 max-mru=1492 interface=ether1-gateway  disabled=no
  
初始化配置命令,可设置IP相关信息
1
  
setup
  

列出所有指令及简短说明:
1
  
?
  

目录切换:
1
  
2
  
3
  
4
  
..
  
#返回上级
  
/
  
#返回主目录
  

IP
配置相关命令:
1
  
2
  
3
  
4
  
5
  
6
  
7
  
8
  
9
  
10
  
ip address print
  
#列出网卡及IP信息
  
ip address add address=192.168.1.22/255.255.255.0 interface=ether1  
  
#网卡1增加IP地址
  
ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1
  
#设置默认路由
  
ip dns set servers=192.168.1.1
  
#设置DNS
  
ip address remove numbers=0
  
#删除ID0IP
  

SNAT&DNAT
1
  
2
  
3
  
4
  
ip firewall nat add chain=srcnat action=masquerade out-interface=ether1
  
#SNAT
  
ip firewall nat add chain=dstnat action=dst-nat protocol=tcp  dst-address=192.168.8.8/32 dst-port=80  to-addresses=192.168.1.8
  
#DNAT
  

PPPOE/ADSL
拨号:
1
  
2
  
interface pppoe-client add user=user password=onovps.com use-peer-dns=yes add-default-route=yes\
  
max-mtu=1492 max-mru=1492 interface=ether1-gateway  disabled=no
  

系统管理相关命令:
1
  
2
  
3
  
4
  
5
  
6
  
7
  
8
  
9
  
10
  
system reboot
  
#重启系统
  
system shutdown
  
#关机
  
system reset-configuration
  
#恢复默认设置
  
system backup save name=20120721.bak
  
#备份配置文件
  
system backup load name=20120721.bak.backup
  
#恢复配置文件
  

系统监控相关命令:
1
  
2
  
3
  
4
  
5
  
6
  
7
  
8
  
9
  
10
  
11
  
12
  
13
  
14
  
15
  
16
  
tool sniffer start
  
#开启数据监听
  
tool sniffer stop
  
#关闭数据监听
  
tool sniffer packet print
  
#列出监控的数的包
  
interface monitor-traffic ether1
  
#监控指定网卡流量
  
user active print
  
#显示当前登录用户
  
ip firewall connection print
  
#显示当前所有连接
  
system resource print
  
#列出系统资源占用
  
system resource monitor
  
#实时监控资源占用
  

配置ROS时区及ntp客户端同步时间:
1
  
2
  
system clock set  time-zone-name=Asia/Shanghai
  
system ntp client set mode=unicast primary-ntp=202.112.31.197  enabled=yes
  
ROS安装界面命令翻译
  
system
  
  
主要是包的基本服务和驱动程序
  
  
ppp
  
  
提供PPP,PPTP,L2TP,PPPoE和ISDN PPP
  
  
dhcp
  
  
DHCP 客户端和服务器
  
  
advanced-tools
  
  
邮件客户端,pingers,netwatch和其他的工具
  
  
arlan
  
  
支持直接序列扩频2.4 2Mbps的Aironet ISA卡
  
  
gps
  
  
支持GPS装置
  
  
hotspot
  
  
允许给无线客户或非安全客户提供公共网络访问
  
  
hotspot-fix
  
  
修复hotspot在2.9.27版本中出现的问题
  
  
isdn
  
  
提供isdn的支持
  
  
lcd
  
  
支持液晶显示器
  
  
ntp
  
  
支持网络时间协议
  
  
radiolan
  
  
提供支持5.8GHz RadioLan卡
  
  
routerboard
  
  
支持路由主板的一些函数和工具
  
  
routing
  
  
支持RIP,OSPF和BGP4协议
  
  
routing-test
  
  
路由的测试包
  
  
rstp-bridge-test
  
  
快速生成树协议桥的测试包
  
  
security
  
  
支持IPSEC,SSH和安全的WinBox连接
  
  
synchronous
  
  
支持Framerelay和Moxa C101,Moxa C502,Farsync,Cyclades PC300,LMC SBE和XPeed同步卡
  
  
telephony
  
  
IP电话的支持
  
  
ups
  
  
智能模式下的APC UPS支持
  
  
user-manager
  
  
用户管理服务
  
  
web-proxy
  
  
HTTP web代理支持
  
  
webproxy-test
  
  
HTTP web代理支持测试包
  
  
wireless
  
  
提供支持Cisco的Aironet卡, prismii和Atheros的无线站和接入点(测试版)
  
  
wireless-legacy
  
  
提供支持Cisco的Aironet卡, prismii和Atheros的无线站和接入点
  
system:默认的system安装包含了
      01.IP
地址管理,ARP协议,静态路由,策略路由,放火墙(包过滤,内容过滤,伪装,和静态的NAT),流量整形(队列方式)ip流量监控,Ros的邻居发现,ip数据包的包装,DNS客户端设置,IP服务(服务器)
      02.
以太网接口的支持
      03.IP over IP
隧道接口的支持
      04.
以太网 over IP隧道接口的支持
      05.
管理以太网ISA
      06.
串口的管理
      07.
本地用户管理
      08.
导入和导出路由器的配置脚本
      09.
备份和恢复路由器的配置
      10.
撤消和重置配置的改变
      11.
网络诊断工具(比如ping,tracert,带宽测试,线路监控)
      12.
桥接的支持
      13.
系统资源包管理
      14.
软件包管理
      15.telnet
客户端和服务器的支持
      16.
本地和远程的日志记录
      17.winbox
服务器以及winbox可执行的一些插件

发表于 2018-9-17 21:57:08 | 显示全部楼层
ROS软路由论坛
谢谢朋友的分享  
发表于 2018-11-30 13:22:00 | 显示全部楼层
漂亮漂亮漂亮漂亮
发表于 2019-6-19 17:52:46 | 显示全部楼层
  谢谢分享  收藏了
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则


Q:2000617 点击留言

Q:2000617|Archiver|ROS软路由论坛 ROSABC.com

GMT+8, 2019-8-26 17:47 , Processed in 0.213662 second(s), 17 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表