ROS软路由论坛 ROSABC.com

 找回密码
 会员注册

QQ登录

只需一步,快速开始

查看: 49265|回复: 116

[Tools调测工具] [E-mail 发送工具] E-mail 工具非常有用,允许从路由发送 e-mail

  [复制链接]
发表于 2013-4-21 05:15:06 | 显示全部楼层 |阅读模式

马上注册成为ROSABC会员,随时发帖回复。

您需要 登录 才可以下载或查看,没有账号?会员注册

x
E-mail 发送工具

E-mail 工具非常有用,允许从路由发送 e-mail,这个工具被用于备份配置和导出网络管理信息,Email 工具用 于纯验证和 TLS 加密,其他模式不支持



操作路径: /tool e-mail

属性

这个子菜单下可以设置 SMTP 服务器

from (字符; 默认: <>)显示接收者的名称或者 email 地址。

password (字符; 默认: "")SMTP 服务器要求验证的密码

server (IPort; 默认: 0.0.0.0:25)SMTP 服务器的 IP 地址和端口

username (字符; 默认: "")SMTP 服务器要求使用的用户名。

Email 发送使用一些命令/tool e-mail send

发送命令采用下面参数:

body (字符; 默认: )邮件的实际信息

file (字符; 默认: ) Email 的附件文件名称

from (字符; 默认: )名称或者 email 地址,. password (字符; 默认: )密码用于 SMTP 服务的验证 server (IPort; 默认: ) IP 地址和 SMTP 服务器端口 subject (字符; 默认: )邮件标题.

tls (yes|no; 默认: yes)是否使用 TLS 加密

to (字符; 默认: )目的 emial 地址

user (字符; 默认: )用于 SMTP 验证的用户名

基本事例

这个事例将说明如何导出配置,并每隔 24 小时发送 email  

1. 配置 SMTP 服务器


[RouterOS@ROSABC] /tool e-mail> set server=10.1.1.1:25 from="router@mydomain.com"

2. 添加新的脚本,并取名称“export-send”

/export file=export
/tool e-mail send to="config@mydomain.com" subject="$[/system identity get name] export)
\
body="$[/system clock get date] configuration file" file=export.rsc

3.添加计划任务(scheduler),并设置运行 export-send 脚本

/system scheduler
add on-event="export-send" start-time=00:00:00 interval=24h

查看下面的接口列表:


[RouterOS@ROSABC] interface> print
Flags: X - disabled, D - dynamic, R - running
# NAME TYPE RX-RATE TX-RATE MTU
0 R ether1 ether 0 0 1500
1 R bridge1 bridge 0 0 1500
2 R ether2 ether 0 0 1500
3 R wlan1 wlan 0 0 1500
[RouterOS@ROSABC] interface>

进入/interface bridge 桥接配置,添加一个桥:


[RouterOS@ROSABC] /interface bridge> add
[RouterOS@ROSABC] /interface bridge> prin Flags: X - disabled, R - running
0 R name="bridge1" mtu=1500 arp=enabled mac-address=00:00:00:00:00:00 protocol-mode=none priority=0x8000 auto-mac=yes
admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 ageing-time=5m

[RouterOS@ROSABC] /interface bridge>

E-mail在winbox下的

操作路径:
游客,如果您要查看本帖隐藏内容请回复



发表于 2013-4-21 11:50:18 | 显示全部楼层
要查看本帖隐藏内容
发表于 2013-5-25 01:56:14 | 显示全部楼层
发表于 2013-5-28 14:34:00 | 显示全部楼层
dsafcsdcddsfvdsdssdf
发表于 2013-6-16 04:09:14 | 显示全部楼层

要查看本帖隐藏内容
发表于 2013-6-17 09:27:04 | 显示全部楼层
see see see see what see
发表于 2013-6-22 01:37:19 | 显示全部楼层
thank you
发表于 2013-8-2 00:20:12 | 显示全部楼层
谢谢楼主分享
发表于 2013-8-6 15:04:03 | 显示全部楼层
回帖看精华。。。。。。。。。。。。。。。。。。。。。。
发表于 2013-8-6 18:36:00 | 显示全部楼层
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则


软路由

不良信息举报Q:2000617|Archiver|ROS软路由论坛 ROSABC.com

GMT+8, 2022-8-19 01:27 , Processed in 1.218071 second(s), 23 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表