ROS软路由论坛 ROSABC.com

 找回密码
 会员注册
查看: 65|回复: 2

[原创] ROS发布自己的网站电影服务器!以及端口映射和回流问题

[复制链接]
发表于 2019-7-23 22:09:13 | 显示全部楼层 |阅读模式
ROS软路由论坛
写这个帖子还是属于基本的新人教学 老鸟请一笑而过!

端口映射做什么用? 举例最好说明
譬如我有个电影服务器在内网 而恰好我的外网就是公网
(现在的家庭基本都是城域网了 坑爹啊 IP都被拿去做交易了!)
这时候 我想要在外面任何地方都能访问我的电影服务器--(嗯 对 我就是想弄点外快好不好^^)
这时候就要用到端口映射

下面我来讲讲端口映射怎么设置
其实这年头大家用ROS都有脚本生成器
那玩意确实好用 防止忘记和省去打命令的时间 尽管也常常出错!

1 首先 在基于正常或者流行的IP伪装安装脚本里面 如:

/ip firewall nat add chain=srcnat action=masquerade src-address=192.168.0.0/24

这个脚本指出了源地址 src-address!有很多网上脚本没有 那种都是不负责任的脚本!为什么?自己去想!

2 然后来看正常端口映射 假设要映射到192.168.0.253  网关:192.168.0.254

固定IP 如202.96.134.134
/ip firewall nat add chain=dstnat dst-address=202.96.134.134 protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.0.253 to-ports=80
ADSL
/ip firewall nat add chain=dstnat src-address=!192.168.0.0/255.255.255.0 dst-address=!192.168.0.254 protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.0.253 to-ports=80

而一般端口映射其实都是针对外网的 其实dst-address不需要强调 所以 最基本端口映射的脚本就是
/ip firewall nat add chain=dstnat  protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.0.253 to-ports=80
是的 无论固定IP 或者ADSL 其实只要上面这条就行!
上面映射了端口后 理论上外网能访问我内网192.168.0.253的服务器了!仅仅理论 因为实际中是不能用80端口的!
为什么? 不好说!
假如我申请了域名(现在域名多如牛毛很便宜 几块钱就一年)或者有花生壳 通过绑定到我的IP后 那么外网也可以用域名访问我的电影服务器!

但是:这里有一个问题! 如果我在内网也想用域名或者外网IP访问我的电影服务器 那你会发现行不通!有人说那我就用
内网192.168.0.253这个地址访问电影服务器就好!这样当然最好! 但有时候我们需要用域名 比如 如果你做的是一个公司的内部网站 或者OA 而且你的公司有分部! 你别指望让那些白痴领导去记住两个IP
那么 这就是第三个问题了!

3 回流
为什么内网不能以域名或者IP202.96.134.134访问192.168.0.253这台服务器呢?因为我们前面的IP伪装共享上网规则
当你访问外网 都是以网关代劳 而NAT规则是除非指定in interface(进入的借口)否则忽略内网--一句话 上面设置后
你就不能脱裤子放屁 用域名或者外网IP202.96.134.134在内网访问电影服务器了 那怎么办?
:加一条端口映射 ....
这条端口映射和原来那条基本是一样的 除了要指定in interface为你的网关网卡!(一般叫lan)
为了避免和原先的NAT重复 原先那条端口映射也需要指定in interface 自然 只能为外网那块网卡(一般叫wan)
也就是说 :
先修改上面的脚本为  如:
/ip firewall nat add chain=dstnat dst-address=202.96.134.134 in-interface=wan protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.0.253 to-ports=80 (多这句in-interface=wan dst-address可以不填 )

然后 再新建一脚本规则
/ip firewall nat add chain=dstnat dst-address=202.96.134.134 in-interface=lan protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.0.253 to-ports=80 (加这句in-interface=lan)
OK 完工
---就是这么简单!
如果还有没有搞明白的 留言留邮箱或者私我!

发表于 2019-7-28 09:34:15 | 显示全部楼层
ROS软路由论坛
头晕了。。有没有域名访问映射的教程

点评

这就是教程啊 说得这么详细 还是不懂?私聊吧  详情 回复 发表于 2019-8-9 00:21
 楼主| 发表于 2019-8-9 00:21:54 | 显示全部楼层
oushixingfu 发表于 2019-7-28 09:34
头晕了。。有没有域名访问映射的教程

这就是教程啊 说得这么详细 还是不懂?私聊吧
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则


Q:2000617 点击留言

Q:2000617|Archiver|ROS软路由论坛 ROSABC.com

GMT+8, 2019-8-26 18:08 , Processed in 0.120678 second(s), 18 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表