ROS软路由论坛 ROSABC.com

 找回密码
 会员注册
查看: 14585|回复: 77

[Configuration基础配置] [ARP 绑定操作] 虽然主机在 IP 网络中是通过 IP 地址通话,

  [复制链接]
发表于 2013-4-21 01:47:08 | 显示全部楼层 |阅读模式
ROS软路由论坛
本帖最后由 rosabc 于 2013-4-21 02:03 编辑

ARP 绑定操作

虽然主机在 IP 网络中是通过 IP 地址通话,但实际上硬件地址(MAC 地址)被用于主机到其他主机的数据传输。地址解析协议 Address resolution protocol (ARP) 是提供硬件地址与 IP 地址之间的解析。每个路由器都一个 ARP 列表,记录 ARP 信息,由 IP 地址和相符合的 MAC 地址构成,一般 ARP 提供动态的 IP 与 MAC 地址对于关系,自动在 ARP 列表中产生。 路 由器通过 ARP 列表的记录来回应各个主机的数据。我们也可通过静态的 ARP 记录,要求路由器只对静态的 ARP 做回应。这 样就可以避免出现如有用户擅自修改 IP 地址或者通过 ARP 病毒影响路由路由器工作。如通过下面的设置:

1. 在 WinBox 中将动态 ARP 设置为静态的 ARP 记录。
游客,如果您要查看本帖隐藏内容请回复


或者通过命令操作:


[RouterOS@ROSABC] ip arp> add address=192.168.1.248 interface=ether1-lan mac-address=00:21:00:56:00:12

同样的我们可以使用:
将所有的的 ARP 记录修改为静态的。

2. 设置 ether1-lan interface 仅回应静态 ARP 的请求,arp=reply-only:
游客,如果您要查看本帖隐藏内容请回复



命令操作如下:


[admin@RB230] > interface ethernet set ether2 arp=reply-only

ARP 双向绑定事例

首先将所有/ip arp 列表中的所有 LAN 口的 ARP 信息变为静态的,我们可以通过脚本做批处理的修改。注意,可能通过脚本命令不一定能将所有的内网的 ARP 参数修改完,可能需要手动添加。

:foreach i in [/ip arp find dynamic=yes interface=LAN] do={
/ip arp add copy-from=$i}

然后设置 LAN 的网卡为:disabled

如果 ARP 功能在接口上被关闭,例如:使用 arp=disabled,来至客户端的 ARP 请求将不被路由器回应,因此 必须添加静态的 ARP 才行。 例如,通过 arp 命令将路由器的 IP 和 MAC 地址必须添加到 windows 工作站中:


[RouterOS@ROSABC] ip arp> /interface ethernet set LAN arp=disabled

现在路由器已经绑定了内网主机的所有 IP 地址后,现在需要对 Windows 电脑做对路由器绑定的设置

C:\> arp -s 10.5.8.254 00-aa-00-62-c6-09

也可以编辑 windows 自己的批处理文件(.dat)操作

第六章 路由设置(Route)

下面的内容介绍了 RouterOS 路由管理,针对目标、源地址和策略路由等,在各种网络环境具体使用哪一种路 由方式,需要根据用户来选择。


需要功能包: system

软件等级: Level1



操作路径: /ip route, /ip route rules

发表于 2013-5-28 10:14:20 | 显示全部楼层
ROS软路由论坛
fdfdfsfsdfsdfsdfsdfsd
发表于 2013-6-19 22:58:44 | 显示全部楼层
要啊要啊
发表于 2013-8-8 14:21:12 | 显示全部楼层
see  see  see  see  see
发表于 2013-8-24 23:21:54 | 显示全部楼层
我要看看,很有用
发表于 2013-8-25 01:54:50 | 显示全部楼层
支持一下。。。。。。
发表于 2013-8-28 14:33:05 | 显示全部楼层
看看学习下,这个不错药顶
发表于 2013-10-11 23:16:45 | 显示全部楼层
好好学习天天成长
发表于 2013-10-16 15:11:59 | 显示全部楼层
学学防火墙设置学学防火墙设置
发表于 2013-10-29 11:49:25 | 显示全部楼层
谢谢参考,大力支持
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

ROS教程版块已全面开放,
即使是新注册的初级会员也可阅读全部内容。

不良信息举报Q:2000617

不良信息举报Q:2000617|Archiver|小黑屋|ROS软路由论坛 ROSABC.com

GMT+8, 2020-9-23 13:44 , Processed in 0.179903 second(s), 20 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表