ROS软路由论坛 ROSABC.com

 找回密码
 会员注册
查看: 60084|回复: 1134

[Configuration基础配置] [第一次登陆 RouterOS] 在你安装完成 RouterOS 后,准备第一次

  [复制链接]
发表于 2013-4-21 01:17:40 | 显示全部楼层 |阅读模式
ROS软路由论坛
本帖最后由 rosabc 于 2013-4-21 01:55 编辑

第一次登陆 RouterOS

在你安装完成 RouterOS 后,准备第一次登陆 RouterOS,这里将告诉你如何连接到 RouterOS

方式1:Console 连接

如果你的设备是 RouterBOARD,没有显示器接口连接功能,你必须找到一条 Console 线(普通的 Console线),或者采用方式 2。

任何 PC 通过标准的 DB9 模式串口线连接到路由器,PC 串口连接的默认设置为每秒位数:9600 bits/s (RouterBOARD 系列串口是 115200 bits/s),使用终端仿真程序(如在 windows 中的超级终端或 SecureCRT,UNIX/Linux 的 minicom)连接到路由器。超级终端的具体参数设置如下:

将 Console 线的一端插到路由设备的 Console 口上,另一端插到 PC 上(运行 windows 或者 linux 操作系统), 如果你 PC 没有 Console 口,你可以使用一个 USB-Serial 适配器(USB 转串口适配器),然后运行一个终端 程序 HyperTerminal 或者 Putty(windowsXP 以前系统都自带有超级终端,Vista 和 win7 可以将 windowsXP 的超级终端文件拷贝直接使用,文件 hypertrm.dll 和 hypertrm.exe)。RouterBOARD 连接参数如下:
游客,如果您要查看本帖隐藏内容请回复

基于 PC 的 RouterOS 连接参数:
1.2.2.jpg
通过以上配置你可以连接到 RouterOS,通过配置参数实现你的要去,具体参考相应的配置手册

串口连接线(Null-modem 连接线)

下面是串口连接线的线序:

在路由器启动完成后,会发出连续两声短触“嘀嘀”的明鸣音,之后在显示屏上,出现登录的提示,如果在终端 显示中,没有提示任何信息,需要检查一下网线或是串口线是否连接好。

串口控制(管理端)功能允许通过一个 MikroTik Router 串行接口访问路由器的串口终端控台一个特殊的串行 接口线通过工作站或者便携式电脑的串口(COM)连接到路由器的串口。在 windows 电脑上常用的串口连接 程序是超级终端(HyperTerminal)。
1.2.3.jpg

串口控制线配置

基于 PC 的 RouterOS 的 DB9 串口线序排列如下:

Router Side (DB9f) Signal Direction Side (DB9f)
1, 6 CD, DSRIN 4
2 RxD IN 3
3 TxD OUT 2
4 DTR OUT 1, 6
5 GND - 5
7 RTS OUT 8
8 CTS IN 7

基于 RouterBOARD 系列的串口线序如下:

DB9f 功能 DB9f DB25f 1+4+6 CD+DTR+DSR 1+4+6 6+8+20
2 RxD 3 2
3 xD 2 3
5 GND 5 7
7+8 RTS+CTS 7+8 4+5

注:MikroTik RouterOS 需要定义以上的串口线序,才可以正常通信。

方式 2,Winbox 和 MAC telnet

你可以下载 winbox 应用程序,通过网上搜索可以找到,或者链接 WinBox。下载完成后你要确定你的电脑与路由器已通过以太网线连接,或者他们两个连接在同一局域网内的交换机上。

运行 winbox,点击
1.2.4.jpg

按钮,winbox 会寻找你的路由器 MAC 地址,如果找到将会显示在 winbox 列表框内, 选择连接并登陆,你可以设置一下初始化参数,但最好配置一个 IP 地址到对应接口上,通过 IP 连接到 RouterOS,因为通过 MAC 连接设备不是 100%的可靠。
1.2.5.jpg

这个方法适用于任何 RouterOS 设备,注意你的 PC 网卡的 MTU 值必须是 1500

方式 3.显示+键盘

如果将 RouterOS 安装到 PC 上,简单的方式就是通过显示+键盘进行配置(注意:RouterBOARD 产品不支持, 仅采用方法 1 和方法 2) ,启动后可以在显示屏上看到如下登陆提示:

MikroTik v5.0
Login:

输入登陆名 admin 回车后,密码为空,你可以看到如下信息 as the login name, and hit enter twice

(because there is no password yet), you will see this screen:

MikroTik RouterOS 5.0 (c) 1999-2011 http://www.rosabc.com/ Terminal ansi detected, using single line input mode


[RouterOS@ROSABC] >

现在你可以配置路由器了,你可以通过 setup 命令进行向导配置

Winbox 与 web 登录

MikroTik RouterOS 内能通过远程配置各种参数,包括 Telnet, SSH, WinBox 和 Webbox。在这里 我们将着重介绍怎样使用 WinBox:
1.2.6.jpg

MAC-telnet 是在路由器没有 IP 地址的情况下或者配置防火墙参数后无法连接,通过路由器网卡 MAC 地址登录的方式远程连接到路由器。MAC-telnet 仅能使用在来自同一个广播域中(因此在网络中不能有路由的存在), 且路由器的网卡应该被启用。注:在 Winbox 中嵌入了通过 MAC 地址连接路由器的功能,并内置了探测工具。 这样在管理员忘记或复位了路由器后,同样可以通过 MAC 登陆到 RouterOS 上,进行图形界面操作。

注:在 winbox2.2.12 后增加了可选择的 MAC 登陆或者 IP 登陆的功能

Winbox 控制台是用于 MikroTik RouterOS 的管理和配置,使用图形管理接口(GUI)。通过连接到 MikroTik 路由器的 HTTP(TCP 80 端口)欢迎界面下载 Winbox.exe 可执行文件 ,下载并保存在你的 Windows 中, 之后直接在你 Windows 电脑上运行 Winbox.exe 文件

下面是对相应的功能键做介绍:

--
1.2.7.jpg

搜索和显示 MNDP (MikroTik Neighbor Discovery Protocol) 或 CDP (Cisco Discovery Protocol) 设备。可以通过该功能键搜索同一子网内 MikroTik 和 Cisco 设备。并能通过 MAC 地址登陆到 MikroTik RouterOS 进行操作。
1.2.8.jpg

注:在 winbox2.2.12 后的版本增加了 MAC 地址和 IP 地址选择功能,可根据搜索内容选择使用 MAC

地址连接或是 IP 地址连接。

--
1.2.9.jpg
通过指定的 IP 地址(默认端口为 80,不许特别指定,如果你修改了端口需要对具体访问端口做自定)

或 MAC 地址(如果路由器在同一子网内)登陆路由器。

--
1.2.10.jpg
保存当前连接列表(当需要运行它们时,只需双击)

--
1.2.11.jpg
删除从列表中选择的项目

--  
1.2.12.jpg
删除所有列表中的项目,清除在本地的缓存,从 wbx 文件导入地址或导出为 wbx 文件
1.2.13.jpg
-- Secure Mode(安全模式):提供保密并在 winbox 和 RouterOS 之间使用 TLS(Transport Layer

Security)协议

-- Keep Password(保存密码):保存密码到本地磁盘的文本文件中

Winbox 控制台使用 TCP 8291 端口,在登陆到路由器后可以通过 Winbox 控制台操作 MikroTik 路由器的配 置并执行与本地控制台同样的任务。

命令功能概述

下面是对 Winbox 控制台的操作按钮:

图标  功能    图标     功能
1.2.14.jpg 添加一条项目
1.2.15.jpg 定义或编辑一个注释
1.2.16.jpg 删除一条存在项目
1.2.17.jpg 查询关键字
1.2.18.jpg 启用一个项目
1.2.19.jpg 撤销操作
1.2.20.jpg 禁用一条项目
1.2.21.jpg 恢复操作

Winbox 常用管理
1.2.22.jpg

故障分析

-- 我能在 Linux 上运行 Winbox?

能,使用 Wine 图形接口,可以运行 Winbox 并连接到 RouterOS。

-- 我不能打开 Winbox 控制台

检查路由器上/ip service print 的 www 服务端口和地址是否正确,确定地址是你能连接到的指定 网络,确定端口为你指定的端口。如果你的服务端口和访问地址被修改,你可以通过下面的命令设置回 默认值 /ip service set www port=80 address=0.0.0.0/0 。Winbox 控制台使用 TCP8291 端口在防火墙中是否做了访问限制。

Webbox 界面

当你配置好 RouterOS 的 IP 地址后,通过在浏览器中输入 http://RouterIP 可以访问到 RouterOS 的

web 页面,我们在右上角输入 RouterOS 的登陆帐号和密码进入 webbox。
1.2.23.jpg
下面是 webbox 的页面,在 webbox 中只能对 RouterOS 的一些基本参数配置,不能进行详细的网络配置,主 要包括 IP 地址、路由、防火墙(建议不要除 NAT 可以使用外,其他不要启用以免无法登陆),基于 simple 的 流量控制、PPPoE 和 DHCP。
1.2.24.jpg
Webfig 配置页面,完全是 winbox 的 web 版本,使管理员有更多方式对 RouterOS 进行管理
1.2.25.jpg
MAC 层访问 (Telnet 与 Winbox)

通过 MAC 地址进行链接是用来访问没有设置 IP 地址的 RouterOS 路由设备. 这种连接类似于 IP 地址连接. 通过 MAC 地址仅在限于 2 台 MikroTik RouterOS 路由器之间进行.



操作路径: /tool mac-server

属性描述

interface (name | all; 默认: all) –连接 MAC 服务器客户端的接口名

all – 所有接口

注:这是一个在菜单选项的接口列表.如果你添加一些接口进列表, 你就能允许通过 mac 地址连接这些接口. Disabled (disabled=yes) 状态的意思是不允许在接口列表中添加的接口通过 mac 地址进行访问. all interfaces 默认设置为允许任何接口进行 mac 地址远程访问.

使只有 ether1 interface 能通过 mac 远程访问服务器:


[RouterOS@ROSABC] tool mac-server> print
Flags: X - disabled
# INTERFACE
0 all

[RouterOS@ROSABC] tool mac-server> remove 0

[RouterOS@ROSABC] tool mac-server> add interface=ether1 disabled=no

[RouterOS@ROSABC] tool mac-server> print
Flags: X - disabled
# INTERFACE
0 ether1

[RouterOS@ROSABC] tool mac-server>

MAC WinBox Server



操作路径: /tool mac-server mac-winbox

属性描述

interface (name | all; 默认: all) – 允许使用 mac 地址的协议连接的接口名

all – 所有接口

注:这是一个在菜单选项的接口列表. 如果你添加接口在列表中, 即允许通过 mac 地址访问到这个接口. Disabled (disabled=yes) 意思是在这些接口中是不允许使用 mac 地址连接的接口.

仅启用 ether1 接口的 MAC 服务器


[RouterOS@ROSABC] tool mac-server mac-winbox> print
Flags: X - disabled
# INTERFACE
0 all

[RouterOS@ROSABC] tool mac-server mac-winbox> remove 0

[RouterOS@ROSABC] tool mac-server mac-winbox> add interface=ether1 disabled=no

[RouterOS@ROSABC] tool mac-server mac-winbox> print
Flags: X - disabled
# INTERFACE
0 ether1

[RouterOS@ROSABC] tool mac-server mac-winbox>

动态监控列表



操作路径: /tool mac-server sessions

属性描述

interface (只读: name) –连接客户端的接口

src-address (只读: MAC address) – 客户 mac 地址(源地址)

uptime (只读: 时间) –客户端连接到服务器上的时间

查看 mac 地址连接访问:


[RouterOS@ROSABC] tool mac-server sessions> print
# INTERFACE SRC-ADDRESS UPTIME
0 wlan1 00:0B:6B:31:08:22 00:03:01
[RouterOS@ROSABC] tool mac-server sessions>

MAC telnet 访问客户端



操作路径: /tool mac-telnet

(MAC address) – 兼容设备的 mac 地址 通过 MAC 地址登陆远程的 RouterOS:


[RouterOS@ROSABC] > /tool mac-telnet 00:02:6F:06:59:42
Login: admin
Password:

[RouterOS@ROSABC] >

发表于 2013-4-24 22:07:22 | 显示全部楼层
ROS软路由论坛
造福大众 惊才绝艳~
发表于 2013-5-28 10:06:32 | 显示全部楼层
asdfsafdsfgdsgdfg
发表于 2013-5-30 14:07:11 | 显示全部楼层
不错,不错
发表于 2013-5-31 14:03:46 | 显示全部楼层
绝对给力
发表于 2013-6-10 10:50:47 | 显示全部楼层
正在学习研究 ros
发表于 2013-6-13 04:10:42 | 显示全部楼层
好帖要顶,楼主的头像还是不错滴

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图

                               
登录/注册后可看大图
发表于 2013-6-13 09:41:12 | 显示全部楼层
SEE SEE SEE SEE SEE
发表于 2013-6-16 03:28:06 | 显示全部楼层
G强!!!!强!!!!
发表于 2013-6-18 11:12:07 | 显示全部楼层
学学学学学
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

ROS教程版块已全面开放,
即使是新注册的初级会员也可阅读全部内容。

网站合作Q:2000617 点击留言

网站合作Q:2000617|Archiver|小黑屋|ROS软路由论坛 ROSABC.com

GMT+8, 2019-11-15 03:39 , Processed in 0.201821 second(s), 20 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表