ROS软路由论坛 ROSABC.com

 找回密码
 会员注册

QQ登录

只需一步,快速开始

查看: 2739|回复: 22

[原创] 动态ip照样可以架设ppp VP恩 服务端

[复制链接]

1

主题

5

帖子

10

活跃分

新手上路

Rank: 1

积分
15
发表于 2020-4-25 15:35:10 | 显示全部楼层 |阅读模式
软路由
本帖最后由 vvv888 于 2020-4-25 15:43 编辑

关键问题是怎么将动态ip告知客户端。
现在有个第三方页面可以存贮您的动态ip。
这样客户端使用脚本就可以查询更新服务器的ip地址。

1
到下面任意一个链接注册一个账号
http://www.99ht.com
http://ip.99ht.com:8077

2  以L2TP为例
请在您作为服务器端的RouterOS设备上开启VP*账号(ppp/secrets),并开启L2TP服务,然后system/scripts增加以下内容的脚本,并在计划任务(system/scheduler)中让其每60秒执行一次。
脚本中红色的user和password,分别替换为您在99ht.com注册的登陆名和密码。
{
local ipaddr
local user "user"
local psw "password"
:set ipaddr [/ip address get [/ip address find interface=pppoe-out1] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
local server "http://ip.99ht.com:8077"
local par "/update.asp?user=$user&ip=$ipaddr&psw=$psw"
/tool fetch url=($server . $par) mode=http
}

3
请在您作为客户端的RouterOS设备建立好VP恩客户端。然后在system/scripts增加如下类似脚本。并添加到计划任务(system/scheduler)中每10-30秒执行一次。
游客,如果您要查看本帖隐藏内容请回复












点击右上角的[设置]-->[个人信息],可更改此处您的签名。

1

主题

5

帖子

10

活跃分

新手上路

Rank: 1

积分
15
 楼主| 发表于 2020-4-25 15:45:09 | 显示全部楼层
帖子中所有的*号  实际是字母N.   记得改哈。
点击右上角的[设置]-->[个人信息],可更改此处您的签名。

10

主题

44

帖子

122

活跃分

初级会员

Rank: 2

积分
191
发表于 2020-5-4 22:05:07 | 显示全部楼层
楼主无敌!jj一百米长
点击右上角的[设置]-->[个人信息],可更改此处您的签名。

0

主题

6

帖子

13

活跃分

初级会员

Rank: 2

积分
116
发表于 2020-5-13 20:00:48 | 显示全部楼层
关健怎么建VP思服务端
点击右上角的[设置]-->[个人信息],可更改此处您的签名。

1

主题

4

帖子

9

活跃分

新手上路

Rank: 1

积分
11
QQ
发表于 2020-5-20 11:05:50 | 显示全部楼层
我来看看技术
点击右上角的[设置]-->[个人信息],可更改此处您的签名。

0

主题

7

帖子

12

活跃分

新手上路

Rank: 1

积分
16
发表于 2020-5-23 13:19:24 | 显示全部楼层
看看怎么搞
点击右上角的[设置]-->[个人信息],可更改此处您的签名。

0

主题

4

帖子

10

活跃分

新手上路

Rank: 1

积分
13
发表于 2020-5-25 13:18:21 | 显示全部楼层
很好  感谢
点击右上角的[设置]-->[个人信息],可更改此处您的签名。

0

主题

5

帖子

18

活跃分

新手上路

Rank: 1

积分
28
发表于 2020-5-26 07:01:40 | 显示全部楼层
不错,我要研究研究
点击右上角的[设置]-->[个人信息],可更改此处您的签名。
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则


软路由

不良信息举报Q:2000617|Archiver|小黑屋|ROS软路由论坛 ROSABC.com

GMT+8, 2021-4-15 12:48 , Processed in 0.285420 second(s), 23 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表