ROS软路由论坛 ROSABC.com

 找回密码
 会员注册
查看: 7957|回复: 58

[Configuration基础配置] [CLI(command Line interface)命令行操作] 命令提示显示路由器

  [复制链接]
发表于 2013-4-21 01:19:47 | 显示全部楼层 |阅读模式
ROS软路由论坛
本帖最后由 rosabc 于 2013-4-21 01:56 编辑

CLI(command Line interface)命令行操作

命令提示显示路由器的身份名称和当前的操作路径,如下:


游客,如果您要查看本帖隐藏内容请回复


命令

在任何操作目录使用‘?’都可用获取在当前目录中的命令信息。


[RouterOS@ROSABC] >

log/ -- 系统日志
quit – 退出控制台
radius/ -- Radius 客户端设置
certificate/ -- 授权管理
special-login/ -- 特殊登录用户
redo – 返回以前执行的操作
driver/ -- 驱动管理
ping – ping 命令
setup – 做基本的系统设置
interface/ -- 接口配置
password – 修改密码
undo – 撤销以前的操作
port/ -- 串口控制
import – 运行导入的配置脚本
snmp/ -- SNMP 设置
user/ -- 用户管理
file/ -- 路由器本地文件存储
system/ -- 系统信息和应用程序
queue/ -- 带宽管理
ip/ -- IP 选项
tool/ -- 诊断工具
ppp/ -- 点对点协议
routing/ -- 各种路由协议设置
export -- 导出脚本


[RouterOS@ROSABC] >
[RouterOS@ROSABC] ip>

.. – 回到根目录
service/ -- IP 服务
socks/ -- SOCKS 4 代理
arp/ -- ARP 项目管理
upnp/ -- UPNP 管理
dns/ -- DNS 设置
address/ -- 地址管理
accounting/ -- 传输记录
the-proxy/ --
vrrp/ -- 虚拟路由冗余协议
pool/ -- IP 地址池
packing/ -- 数据包封装设置 neighbor/ -- 邻居
route/ -- 路由管理
firewall/ -- 防火墙管理
dhcp-client/ -- DHCP 客户端设置
dhcp-relay/ -- DHCP 中继设置
dhcp-server/ -- DHCP 服务设置
hotspot/ -- HotSpot 管理
ipsec/ -- IP 安全设置
web-proxy/ -- HTTP 代理
export --导出配置


[RouterOS@ROSABC] ip>

上面是对可用命令和目录的简短描述,在下面的例子中,你可用通过输入目录名称移动到不同的目录中去。


[RouterOS@ROSABC] > | 根目录

[RouterOS@ROSABC] > driver | 输入'driver'进入到驱动管理目录中

[RouterOS@ROSABC] driver> / | 输入'/'从任何目录中回到根目录

[RouterOS@ROSABC] > interface | 输入'interface'进入接口管理目录中

[RouterOS@ROSABC] interface> /ip | 输入'/ip'从任何目录进入 IP 管理目录

[RouterOS@ROSABC] ip> |

一个指令或一个变量参数不需要完整的输入,如果是含糊不清的指令或变量参数需要完整的输入。如输入interface 时,你只要输入 in 或 int,需要显示完整的指令可以使用[Tab]键通过指令的组合,可以在当前的目录执行在不同目录操作,如:


[RouterOS@ROSABC] ip route> print 打印路由表
[RouterOS@ROSABC] ip route> .. address print 打印 IP 地址列表
[RouterOS@ROSABC] ip route> /ip address print 打印 IP 地址列表

指令执行概述

Command

指令

command [Enter]

执行指令

[--]

显示该目录中的所有指令列表

command [--]

显示指令的帮助和变量列表

command argument [--]

显示指令的变量帮助

[Tab]

使指令/字段完整,如果输入内容含糊不清,第二次键入 [Tab]会给出存在的选项

/

移动到根目录

/command

执行根目录中的指令

..

移动到上一级目录

""

指定一个空字符串

在配置 IP 地址中,配置'address'和'netmask'参数时,在许多事例中你可以将 IP 地址和子网掩码一起定义,

也可以将子网掩码单独定义,这两种方式是相同的,例如下面的两个输入是等价的:

/ip address add address 10.0.0.1/24 interface ether1
/ip address add address 10.0.0.1 netmask 255.255.255.0 interface ether1

基本操作命令

接口管理(Interface Management)

在配置 IP 地址和路由前,如果你有即插即用卡安装到路由器中,请检查/interface 中的接口列表,多数情况下 设备驱动会自动安装,并且相关的接口信息会显示在/interface print 列表中,例如:


[RouterOS@ROSABC] interface> print
Flags: X - disabled, D - dynamic, R - running
# NAME TYPE RX-RATE TX-RATE MTU
0 R ether1 ether 0 0 1500
1 R ether2 ether 0 0 1500
2 X wavelan1 wavelan 0 0 1500
3 X prism1 wlan 0 0 1500

[RouterOS@ROSABC] interface>

如果你想使用这些设备,一般都需要启用,使用/interface enable name 指令给出接口名称或标号启用, 例如:


[RouterOS@ROSABC] interface> print
Flags: X - disabled, D - dynamic, R - running
# NAME TYPE RX-RATE TX-RATE MTU
0 X ether1 ether 0 0 1500
1 X ether2 ether 0 0 1500

[RouterOS@ROSABC] interface> enable 0
[RouterOS@ROSABC] interface> enable ether2


[RouterOS@ROSABC] interface> print
Flags: X - disabled, D - dynamic, R - running
# NAME TYPE RX-RATE TX-RATE MTU
0 R ether1 ether 0 0 1500
1 R ether2 ether 0 0 1500

[RouterOS@ROSABC] interface>

接口的名称能通过/interface set 指令来改变其描述:


[RouterOS@ROSABC] interface> set ether1 name=Local; set ether2 name=Public

[RouterOS@ROSABC] interface> print
Flags: X - disabled, D - dynamic, R - running
# NAME TYPE RX-RATE TX-RATE MTU
0 R Local ether 0 0 1500
1 R Public ether 0 0 1500
[RouterOS@ROSABC] interface>

通过 add 命令添加规则,如添加 IP 地址操作:


[admin@Office] /ip address> prin
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 10.200.15.1/24 10.200.15.0 10.200.15.255 lan
1 D 222.212.60.227/32 222.212.48.1 0.0.0.0 ADSL

[admin@Office] /ip address> add address=192.168.10.1/24 interface=lan
[admin@Office] /ip address> prin
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 10.200.15.1/24 10.200.15.0 10.200.15.255 lan
1 D 222.212.60.227/32 222.212.48.1 0.0.0.0 ADSL
2 192.168.10.1/24 192.168.10.0 192.168.10.255 lan

[admin@Office] /ip address>

通过 remove 命令删除不需要的规则


[admin@Office] /ip firewall filter> prin
Flags: X - disabled, I - invalid, D - dynamic
0 X chain=forward action=drop layer7-protocol=qq
1 X chain=forward action=drop dst-address-list=qq
2 X chain=forward action=log log-prefix=""
[admin@Office] /ip firewall filter> remove 2
[admin@Office] /ip firewall filter> prin Flags: X - disabled, I - invalid, D - dynamic
0 X chain=forward action=drop layer7-protocol=qq
1 X chain=forward action=drop dst-address-list=qq


[admin@Office] /ip firewall filter>

Setup 指令

当初始化路由器时,通过使用/setup 指令设置下列配置内容:

-- 重新设置路由器配置

-- 载入接口驱动

-- 配置 IP 地址和网关

-- 设置 DHCP 客户端

-- 设置 DHCP 服务端  

-- 设置 pppoe 客户端

-- 设置 pptp 客户端

使用 Setup 指令,在路由器上配置 IP 地址,执行/setup 指令行:


[RouterOS@ROSABC] > setup
Setup uses Safe Mode. It means that all changes that are made during setup are reverted in case of error, or if Ctrl-C is used to abort setup. To keep changes exit setup using the 'x' key.
[Safe Mode taken]
Choose options by pressing one of the letters in the left column, before dash. Pressing 'x' will exit current menu, pressing Enter key will select the entry that is marked by an '*'. You can abort setup at any time by pressing Ctrl-C.
Entries marked by '+' are already configured. Entries marked by '-' cannot be used yet.
Entries marked by 'X' cannot be used without installing additional packages. r - reset all router configuration
+ l - load interface driver
* a - configure ip address and gateway d - setup dhcp client
s - setup dhcp server
p - setup pppoe client t - setup pptp client
x - exit menu
your choice [press Enter to configure ip address and gateway]: a

配置 IP 地址和网关,输入 a 或[Enter]

* a - add ip address
- g - setup default gateway x - exit menu
your choice [press Enter to add ip address]: a

选择 a 添加一个 IP 地址,首先,设置程序将要询问你选择那一个接口添加 IP 地址,如果设置程序没有指定出, 合适的接口,可以通过键入[Tab]两次,查看可选的接口。 在接口选择后,分配 IP 地址和子网淹码:
游客,如果您要查看本帖隐藏内容请回复


发表于 2013-4-29 21:31:04 | 显示全部楼层
ROS软路由论坛
谢谢,学习了
发表于 2013-4-28 10:55:32 | 显示全部楼层
..................
发表于 2013-5-3 09:11:44 | 显示全部楼层
好贴,支持下
发表于 2013-5-28 09:59:50 | 显示全部楼层
ertretretrytryu
发表于 2013-8-8 14:23:26 | 显示全部楼层
see  see  see   see   see
发表于 2013-5-30 15:28:10 | 显示全部楼层
rwtertwetwet
发表于 2013-10-2 18:53:29 | 显示全部楼层
还不会!!!!!!!!!
发表于 2013-10-29 11:52:47 | 显示全部楼层
谢谢参考,大力支持
发表于 2013-10-29 11:56:28 | 显示全部楼层
学习学习学习学习学习学习学习学习学习学习学习学习
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

ROS教程版块已全面开放,
即使是新注册的初级会员也可阅读全部内容。

不良信息举报Q:2000617 点击留言

不良信息举报Q:2000617|Archiver|小黑屋|ROS软路由论坛 ROSABC.com

GMT+8, 2020-3-30 04:50 , Processed in 0.177763 second(s), 18 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表