ROS软路由论坛 ROSABC.com

 找回密码
 会员注册

QQ登录

只需一步,快速开始

查看: 25293|回复: 56

[PPPoE拨号认证] [PPPoE Server 设置] 操作路径: /interface pppoe-server server PPPoE ser

  [复制链接]
发表于 2013-4-21 03:53:42 | 显示全部楼层 |阅读模式

马上注册成为ROSABC会员,随时发帖回复。

您需要 登录 才可以下载或查看,没有帐号?会员注册

x
PPPoE Server 设置



操作路径: /interface pppoe-server server

PPPoE server (access concentrator)支持在每一个接口上的多服务,需要设置不同的 service 名称 ,当前 PPPoE server的吞吐量在一个 Celeron 600 CPU 测试达到 160 Mb/s ,如果使用更高性能的 CPU,吞吐量将会程比例的增加。

service-name (文本) – PPPoE 服务名称

mtu (整型; 默认: 1480) – 最大传输单位。最适合的 MTU 值(以避免以太网连接的 1500-byte,设置为 1480 以避免 数据包的重复存储)

mru (整型; default: 1480) – 最大接受单位。最适合的 MRU 值(以避免以太网连接的 1500-byte,设置为 1480 以避 免数据包的重复存储)

mrru (整型: 512..65535; 默认: disabled) – 在连接中能被接收的最大数据包长度。如一个数据包比隧道 的 MTU 值大时,将会被分割到多个数据包中,允许实际大小的 IP 或以太网的数据包发送到隧道。

authentication (多种选择:mschap2 | mschap1 | chap | pap; 默认: mschap2, mschap1, chap, pap) – 验

证算法

keepalive-timeout – 定义时间周期(秒) 连接开始后路由器每秒钟会发出 keepalive 数据包。如果在设定的时间周期内 没有传输和没有 keepalive 回应,客户端将会被认为失去连接。  

one-session-per-host (yes | no; 默认: no) – 每次只允许一个主机对话连接 (MAC 地址被确定). 如果主机将试着 去建立一个新的对话连接,旧的一个将会被关闭。

default-profile (名称; 默认: default) – 使用默认的策略配置

max-sessions (整形; 默认: 0) – AC 能服务的最大客户端数量

0 – 没有限制

interface (名称) – 客户端连接的网卡接口

注:keepalive-timeout 值通常情况下设置为 10。如果你设置为 0,路由器将不会断开客户端,直到他们自己注销或 是路由器重启该用户帐号才会断开。解决这个问题,one-session-per-host 属性需启用

安全提示:请不要分配一个 IP 地址到 PPPoE 的物理网卡上,避免出现用户不通过 PPPoE 验证即可上网的情况。 明确的讲 MRRU 意思为基于单连接的 MP,该协议被为拆分大数据包为更小的。在 windows 下在网络属性下,设置按钮中打开“为单链路连接协商多重链接”MRRU 是强行设置为 1614。这个设置有益于超载线路 MTU 探 测失败。且 MP 协议应在双方都被启用。
游客,如果您要查看本帖隐藏内容请回复



基于 802.11g 无线网络的 PPPoE 服务

在无线网络中,服务器可以设置在一个访问节点(Access Point),任意一个 RouterOS 客户端或是 Windows 客户端都可 以连接到访问节点的 PPPoE 认证。无线网卡的 MTU 可以设置为 1600,因此接口上的 MTU 设置为 1500,这可以充分利于1500byte 传输数据包,并避免 MTU 比 1500 低出现的任何问题。

让我们考虑下面的配置,MikroTik 无线 AP 能使无线用户端通过验证后访问到本地的网络:
游客,如果您要查看本帖隐藏内容请回复



首先,需要配置无线网卡:


[admin@PPPoE-Server] interface wireless> set 0 mode=ap-bridge \
frequency=2442 band=2.4ghz-b/g ssid=mt disabled=no

[admin@PPPoE-Server] interface wireless> print
Flags: X - disabled, R - running
0 name="wlan1" mtu=1500 mac-address=00:01:24:70:53:04 arp=enabled disable-running-check=no interface-type=Atheros AR5211
radio-name="000124705304" mode=station ssid="mt" area=""
frequency-mode=superchannel country=no_country_set antenna-gain=0 frequency=2412 band=2.4ghz-b scan-list=default rate-set=default supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps
supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,
54Mbps
basic-rates-b=1Mbps basic-rates-a/g=6Mbps max-station-count=2007 ack-timeout=dynamic tx-power=default tx-power-mode=default
noise-floor-threshold=default periodic-calibration=default
burst-time=disabled fast-frames=no dfs-mode=none antenna-mode=ant-a wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no
update-stats-interval=disabled default-authentication=yes
default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no security-profile=default disconnect-timeout=3s
on-fail-retry-time=100ms preamble-mode=both


[admin@PPPoE-Server] interface wireless>

现在,配置以太网卡,添加默认 IP 地址和设置默认路由:


[admin@PPPoE-Server] ip address> add address=10.1.0.3/24 interface=Local

[admin@PPPoE-Server] ip address> print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 10.1.0.3/24 10.1.0.0 10.1.0.255 Local

[admin@PPPoE-Server] ip address> /ip route
[admin@PPPoE-Server] ip route> add gateway=10.1.0.1
[admin@PPPoE-Server] ip route> print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf
# DST-ADDRESS G GATEWAY DISTANCE INTERFACE
0 ADC 10.1.0.0/24 Local
1 A S 0.0.0.0/0 r 10.1.0.1 1 Local

[admin@PPPoE-Server] ip route> /interface ethernet

[admin@PPPoE-Server] interface ethernet> set Local arp=proxy-arp

[admin@PPPoE-Server] interface ethernet> print
Flags: X - disabled, R - running
# NAME MTU MAC-ADDRESS ARP
0 R Local 1500 00:0C:42:03:25:53 proxy-arp

[admin@PPPoE-Server] interface ethernet>

添加 PPPoE server 到无线网卡上:


[admin@PPPoE-Server] interface pppoe-server server> add interface=wlan1 \
service-name=mt one-session-per-host=yes disabled=no
[admin@PPPoE-Server] interface pppoe-server server> print Flags: X - disabled
0 service-name="mt" interface=wlan1 max-mtu=1480 max-mru=1480 authentication=pap,chap,mschap1,mschap2 keepalive-timeout=10
one-session-per-host=yes max-sessions=0 default-profile=default

[admin@PPPoE-Server] interface pppoe-server server>

最后,设置 PPPoE clients:


[admin@PPPoE-Server] ip pool> add name=pppoe ranges=10.1.0.100-10.1.0.200
[admin@PPPoE-Server] ip pool> print
# NAME RANGES
0 pppoe 10.1.0.100-10.1.0.200
[admin@PPPoE-Server] ip pool> /ppp profile

[admin@PPPoE-Server] ppp profile> set default use-encryption=yes \
local-address=10.1.0.3 remote-address=pppoe

[admin@PPPoE-Server] ppp profile> print

Flags: * - default
0 * name="default" local-address=10.1.0.3 remote-address=pppoe
use-compression=no use-vj-compression=no use-encryption=yes only-one=no change-tcp-mss=yes
1 * name="default-encryption" use-compression=default
use-vj-compression=default use-encryption=yes only-one=default change-tcp-mss=default

[admin@PPPoE-Server] ppp profile> .. secret

[admin@PPPoE-Server] ppp secret> add name=w password=wkst service=pppoe
[admin@PPPoE-Server] ppp secret> add name=l password=ltp service=pppoe
[admin@PPPoE-Server] ppp secret> print
Flags: X - disabled
# NAME SERVICE CALLER-ID PASSWORD PROFILE REMOTE-ADDRESS
0 w pppoe wkst default 0.0.0.0
1 l pppoe ltp default 0.0.0.0
[admin@PPPoE-Server] ppp secret>

注: 在 Windows XP 中的 PPoE 客户端内建加密功能,但 RASPPPOE 没有。因此,如果计划不在支持比 Windows XP 老 的 Windows 客户端,推荐在 default 规则配置把 require-encryption 值选择位 yes。在其他一些应用中,可以服务 设置为接受为加密的数据。


发表于 2013-5-19 05:02:40 | 显示全部楼层
真心需要   学习啊
发表于 2013-5-21 16:04:28 | 显示全部楼层
发表于 2013-5-28 09:18:26 | 显示全部楼层
fgfdgfdgdfhfdhgfhgfhgfh
发表于 2013-5-31 15:41:08 | 显示全部楼层
来看看。。。。。。。。。。
发表于 2013-8-9 17:25:34 | 显示全部楼层
see  see  see  see  see
发表于 2013-9-17 17:12:50 | 显示全部楼层
让我瞧瞧吧!!!!!!!!!!!!!!!!!!!!!!!!!!:@:@
发表于 2013-10-31 21:26:35 | 显示全部楼层
谢谢参考,大力支持
发表于 2013-12-24 11:16:59 | 显示全部楼层
回帖是一种美德!!!
发表于 2014-3-26 09:35:26 | 显示全部楼层
给力,学习! thanks very much!
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则


软路由

不良信息举报Q:2000617|Archiver|ROS软路由论坛 ROSABC.com

GMT+8, 2022-5-20 12:49 , Processed in 0.092019 second(s), 25 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表